Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "System call tracing tool" |
| 2 | HOMEPAGE = "http://strace.io" |
| 3 | DESCRIPTION = "strace is a diagnostic, debugging and instructional userspace utility for Linux. It is used to monitor and tamper with interactions between processes and the Linux kernel, which include system calls, signal deliveries, and changes of process state." |
| 4 | SECTION = "console/utils" |
| 5 | LICENSE = "LGPL-2.1-or-later & GPL-2.0-or-later" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=59a33f0a3e6122d67c0b3befccbdaa6b" |
| 7 | |
| 8 | SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \ |
| 9 | file://update-gawk-paths.patch \ |
| 10 | file://Makefile-ptest.patch \ |
| 11 | file://run-ptest \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | file://ptest-spacesave.patch \ |
| 13 | file://0001-strace-fix-reproducibilty-issues.patch \ |
| 14 | file://skip-load.patch \ |
| 15 | file://0001-configure-Use-autoconf-macro-to-detect-largefile-sup.patch \ |
| 16 | file://0002-tests-Replace-off64_t-with-off_t.patch \ |
| 17 | " |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 18 | SRC_URI[sha256sum] = "dfb051702389e1979a151892b5901afc9e93bbc1c70d84c906ade3224ca91980" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 19 | |
| 20 | inherit autotools ptest |
| 21 | |
| 22 | # Not yet ported to rv32 |
| 23 | COMPATIBLE_HOST:riscv32 = "null" |
| 24 | |
| 25 | PACKAGECONFIG:class-target ??= "\ |
| 26 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ |
| 27 | " |
| 28 | |
| 29 | PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,bluez5" |
| 30 | PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind" |
| 31 | |
| 32 | EXTRA_OECONF += "--enable-mpers=no --disable-gcc-Werror" |
| 33 | |
| 34 | CFLAGS:append:libc-musl = " -Dsigcontext_struct=sigcontext" |
| 35 | |
| 36 | TESTDIR = "tests" |
| 37 | PTEST_BUILD_HOST_PATTERN = "^(DEB_CHANGELOGTIME|RPM_CHANGELOGTIME|WARN_CFLAGS_FOR_BUILD|LDFLAGS_FOR_BUILD)" |
| 38 | |
| 39 | do_compile_ptest() { |
| 40 | oe_runmake -C ${TESTDIR} buildtest-TESTS |
| 41 | } |
| 42 | |
| 43 | do_install_ptest() { |
| 44 | oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR} |
| 45 | mkdir -p ${D}${PTEST_PATH}/build-aux |
| 46 | mkdir -p ${D}${PTEST_PATH}/src |
| 47 | install -m 755 ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/ |
| 48 | install -m 644 ${B}/src/config.h ${D}${PTEST_PATH}/src/ |
| 49 | sed -i -e '/^src/s/strace.*[0-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile |
| 50 | } |
| 51 | |
| 52 | RDEPENDS:${PN}-ptest += "make coreutils grep gawk sed" |
| 53 | |
| 54 | RDEPENDS:${PN}-ptest:append:libc-glibc = "\ |
| 55 | locale-base-en-us.iso-8859-1 \ |
| 56 | " |
| 57 | |
| 58 | BBCLASSEXTEND = "native" |