Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "VA-API support to GStreamer" |
| 2 | HOMEPAGE = "https://gstreamer.freedesktop.org/" |
| 3 | DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \ |
| 4 | based plugins for GStreamer and helper libraries: `vaapidecode', \ |
| 5 | `vaapiconvert', and `vaapisink'." |
| 6 | |
| 7 | REALPN = "gstreamer-vaapi" |
| 8 | |
| 9 | LICENSE = "LGPL-2.1-or-later" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" |
| 11 | |
| 12 | SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz" |
| 13 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 14 | SRC_URI[sha256sum] = "a9a550267c9584df0e8c70434d30476e8fd0018b733c1c1ee33deaf422bdb24b" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | |
| 16 | S = "${WORKDIR}/${REALPN}-${PV}" |
| 17 | DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad" |
| 18 | |
| 19 | inherit meson pkgconfig features_check upstream-version-is-even |
| 20 | |
| 21 | REQUIRED_DISTRO_FEATURES ?= "opengl" |
| 22 | |
| 23 | EXTRA_OEMESON += " \ |
| 24 | -Ddoc=disabled \ |
| 25 | -Dexamples=disabled \ |
| 26 | -Dtests=enabled \ |
| 27 | " |
| 28 | |
| 29 | PACKAGES =+ "${PN}-tests" |
| 30 | |
| 31 | # OpenGL packageconfig factored out to make it easy for distros |
| 32 | # and BSP layers to pick either glx, egl, or no GL. By default, |
| 33 | # try detecting X11 first, and if found (with OpenGL), use GLX, |
| 34 | # otherwise try to check if EGL can be used. |
| 35 | PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \ |
| 36 | bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \ |
| 37 | '', d), d)}" |
| 38 | |
| 39 | PACKAGECONFIG ??= "drm encoders \ |
| 40 | ${PACKAGECONFIG_GL} \ |
| 41 | ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}" |
| 42 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 43 | PACKAGECONFIG[drm] = "-Ddrm=enabled,-Ddrm=disabled,udev libdrm" |
| 44 | PACKAGECONFIG[egl] = "-Degl=enabled,-Degl=disabled,virtual/egl" |
| 45 | PACKAGECONFIG[encoders] = "-Dencoders=enabled,-Dencoders=disabled" |
| 46 | PACKAGECONFIG[glx] = "-Dglx=enabled,-Dglx=disabled,virtual/libgl" |
| 47 | PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,wayland-native wayland wayland-protocols" |
| 48 | PACKAGECONFIG[x11] = "-Dx11=enabled,-Dx11=disabled,virtual/libx11 libxrandr libxrender" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 49 | |
| 50 | FILES:${PN} += "${libdir}/gstreamer-*/*.so" |
| 51 | FILES:${PN}-dbg += "${libdir}/gstreamer-*/.debug" |
| 52 | FILES:${PN}-dev += "${libdir}/gstreamer-*/*.a" |
| 53 | FILES:${PN}-tests = "${bindir}/*" |