Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | # Simple initramfs image. Mostly used for live images. |
| 2 | DESCRIPTION = "Small image capable of booting a device. The kernel includes \ |
| 3 | the Minimal RAM-based Initial Root Filesystem (initramfs), which one can use \ |
| 4 | to check the hardware efficiently." |
| 5 | |
| 6 | PACKAGE_INSTALL = "initramfs-debug busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}" |
| 7 | |
| 8 | # Do not pollute the initrd image with rootfs features |
| 9 | IMAGE_FEATURES = "" |
| 10 | |
| 11 | export IMAGE_BASENAME = "initramfs-debug-image" |
| 12 | IMAGE_LINGUAS = "" |
| 13 | |
| 14 | LICENSE = "MIT" |
| 15 | |
| 16 | IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}" |
| 17 | inherit core-image |
| 18 | |
| 19 | IMAGE_ROOTFS_SIZE = "8192" |
| 20 | IMAGE_ROOTFS_EXTRA_SPACE = "0" |
| 21 | |
| 22 | BAD_RECOMMENDATIONS += "busybox-syslog" |