Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | require initramfs-kexecboot-image.bb |
| 2 | |
| 3 | SUMMARY = "Initramfs image for kexecboot kernel (klibc-static binaries)" |
| 4 | |
| 5 | # We really need just kexecboot, kexec and ubiattach |
| 6 | # statically compiled against klibc |
| 7 | IMAGE_INSTALL = "kexecboot-klibc kexec-klibc ubiattach-klibc" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 8 | |
| 9 | python () { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 10 | if d.getVar('TARGET_ARCH') == "nios2": |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | raise bb.parse.SkipRecipe("'nios2' not supported arch") |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 12 | } |