Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "TinyALSA is a small library to interface with ALSA in \ |
| 2 | the Linux kernel. It is a lightweight alternative to libasound." |
| 3 | HOMEPAGE = "https://github.com/tinyalsa/tinyalsa" |
| 4 | SECTION = "libs/multimedia" |
| 5 | |
| 6 | LICENSE = "BSD-3-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://NOTICE;md5=dbdefe400d894b510a9de14813181d0b" |
| 8 | |
| 9 | SRCREV = "67b9210d344c34e8d1aa0cfe638abce71c5221ca" |
| 10 | SRC_URI = "git://github.com/tinyalsa/tinyalsa" |
| 11 | PV = "1.1.1+git${SRCPV}" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit cmake |
| 16 | |
| 17 | # tinyalsa is built as a static library. Enable PIC to avoid relocation |
| 18 | # errors like these: |
| 19 | # |
| 20 | # unresolvable R_AARCH64_ADR_PREL_PG_HI21 relocation against symbol `stderr@@GLIBC_2.17' |
| 21 | CFLAGS += " -fPIC -DPIC " |
| 22 | |
| 23 | PACKAGES =+ "${PN}-tools" |
| 24 | FILES_${PN}-tools = "${bindir}/*" |