Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Paho MQTT - C libraries for the MQTT and MQTT-SN protocols" |
| 2 | DESCRIPTION = "Client implementation of open and standard messaging protocols for Machine-to-Machine (M2M) and Internet of Things (IoT)." |
| 3 | HOMEPAGE = "http://www.eclipse.org/paho/" |
| 4 | SECTION = "console/network" |
| 5 | LICENSE = "EPL-1.0 | EDL-1.0" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = " \ |
| 8 | file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \ |
| 9 | file://epl-v10;md5=659c8e92a40b6df1d9e3dccf5ae45a08 \ |
| 10 | file://notice.html;md5=a00d6f9ab542be7babc2d8b80d5d2a4c \ |
| 11 | file://about.html;md5=dcde438d73cf42393da9d40fabc0c9bc \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI = "git://github.com/eclipse/paho.mqtt.c;protocol=http" |
| 15 | |
| 16 | SRCREV = "9f715d0862a8e16099b5837c4e53a1bf6a6a0675" |
| 17 | |
| 18 | DEPENDS = "openssl" |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | inherit cmake |
| 23 | |
| 24 | do_install_append() { |
| 25 | # paho-mqtt installes some thing that we don't want. |
| 26 | rm -rf ${D}${prefix}/samples |
| 27 | find ${D}${prefix} -maxdepth 1 -type f -delete |
| 28 | } |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 29 | |
| 30 | EXTRA_OECMAKE = "-DPAHO_WITH_SSL=ON" |