Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | HOMEPAGE = "http://www.alumnit.ca/wiki/?WvDial" |
| 2 | DESCRIPTION = "WvDial is a program that makes it easy to connect your Linux workstation to the Internet." |
| 3 | |
| 4 | LICENSE = "LGPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=55ca817ccb7d5b5b66355690e9abc605" |
| 6 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 7 | inherit pkgconfig |
| 8 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 9 | DEPENDS = "wvstreams" |
| 10 | RDEPENDS_${PN} = "ppp" |
| 11 | |
| 12 | SRC_URI = "http://${BPN}.googlecode.com/files/${BP}.tar.bz2 \ |
| 13 | file://typo_pon.wvdial.1.patch \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 14 | file://musl-support.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 15 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 16 | SRC_URI[md5sum] = "37e9a2d664effe4efd44c0e1a20136de" |
| 17 | SRC_URI[sha256sum] = "99906d9560cbdbc97e1855e7b0a7169f1e11983be3ac539140423f09debced82" |
| 18 | |
| 19 | EXTRA_OEMAKE = "" |
| 20 | export WVLINK="${LD}" |
| 21 | |
| 22 | PARALLEL_MAKE = "" |
| 23 | |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 24 | do_configure() { |
| 25 | sed -i 's/LDFLAGS+=-luniconf/LIBS+=-luniconf/' ${S}/Makefile |
| 26 | } |
| 27 | |
| 28 | do_install() { |
| 29 | oe_runmake prefix=${D}/usr PPPDIR=${D}/etc/ppp/peers install |
| 30 | } |