Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "A python module for system storage configuration" |
| 2 | HOMEPAGE = "http://fedoraproject.org/wiki/blivet" |
| 3 | LICENSE = "LGPLv2+" |
| 4 | SECTION = "devel/python" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | B = "${S}" |
| 10 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame^] | 11 | SRCREV = "9b5ad2d5b5df159963e1c6c24523e1dfe1f71435" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | SRC_URI = "git://github.com/rhinstaller/blivet;branch=3.1-release \ |
| 13 | file://0001-comment-out-selinux.patch \ |
| 14 | file://0002-run_program-support-timeout.patch \ |
| 15 | file://0003-support-infinit-timeout.patch \ |
| 16 | file://0004-fix-new.roots-object-is-not-iterable.patch \ |
| 17 | file://0005-fix-incorrect-timeout-while-system-time-changed.patch \ |
| 18 | file://0006-tweak-btrfs-packages.patch \ |
| 19 | file://0007-invoking-mount-with-infinite-timeout.patch \ |
| 20 | file://0008-use-oe-variable-to-replace-hardcoded-dir.patch \ |
| 21 | file://0009-invoking-fsck-with-infinite-timeout.patch \ |
| 22 | file://0010-invoking-mkfs-with-infinite-timeout.patch \ |
| 23 | file://0011-invoking-dd-with-infinite-timeout.patch \ |
| 24 | " |
| 25 | |
| 26 | UPSTREAM_CHECK_GITTAGREGEX = "blivet-(?P<pver>\d+(\.\d+)+)$" |
| 27 | |
| 28 | inherit distro_features_check |
| 29 | REQUIRED_DISTRO_FEATURES = "systemd" |
| 30 | |
| 31 | inherit setuptools3 python3native |
| 32 | |
| 33 | RDEPENDS_${PN} = "python3-pykickstart python3-pyudev \ |
| 34 | parted python3-pyparted multipath-tools \ |
| 35 | lsof cryptsetup libblockdev \ |
| 36 | libbytesize \ |
| 37 | " |
| 38 | |
| 39 | FILES_${PN} += " \ |
| 40 | ${datadir}/dbus-1/system-services \ |
| 41 | " |
| 42 | |
| 43 | inherit systemd |
| 44 | |
| 45 | SYSTEMD_AUTO_ENABLE = "disable" |
| 46 | SYSTEMD_SERVICE_${PN} = "blivet.service" |