Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
| 2 | |
| 3 | LICENSE = "MIT" |
| 4 | |
| 5 | SRC_URI = "file://hello.c \ |
| 6 | file://gdb.sh \ |
| 7 | " |
| 8 | |
| 9 | S = "${WORKDIR}" |
| 10 | |
| 11 | do_compile () { |
| 12 | ${CC} hello.c -o hello1 ${CFLAGS} ${LDFLAGS} |
| 13 | } |
| 14 | |
| 15 | do_install () { |
| 16 | install -d ${D}${bindir} |
| 17 | install -m 755 ${WORKDIR}/gdb.sh ${D}${bindir}/ |
| 18 | install -m 755 hello1 ${D}${bindir}/hello1 |
| 19 | ln ${D}${bindir}/hello1 ${D}${bindir}/hello2 |
| 20 | |
| 21 | install -d ${D}${libexecdir} |
| 22 | ln ${D}${bindir}/hello1 ${D}${libexecdir}/hello3 |
| 23 | ln ${D}${bindir}/hello1 ${D}${libexecdir}/hello4 |
| 24 | |
| 25 | dd if=/dev/zero of=${D}${bindir}/sparsetest bs=1 count=0 seek=1M |
| 26 | } |
| 27 | |
| 28 | RDEPENDS_${PN}-gdb += "gdb" |
| 29 | PACKAGES =+ "${PN}-gdb" |
| 30 | FILES_${PN}-gdb = "${bindir}/gdb.sh" |