Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | UNINATIVE_LOADER ?= "${UNINATIVE_STAGING_DIR}-uninative/${BUILD_ARCH}-linux/lib/${@bb.utils.contains('BUILD_ARCH', 'x86_64', 'ld-linux-x86-64.so.2', '', d)}${@bb.utils.contains('BUILD_ARCH', 'i686', 'ld-linux.so.2', '', d)}${@bb.utils.contains('BUILD_ARCH', 'aarch64', 'ld-linux-aarch64.so.1', '', d)}" |
Brad Bishop | 37a0e4d | 2017-12-04 01:01:44 -0500 | [diff] [blame] | 2 | UNINATIVE_STAGING_DIR ?= "${STAGING_DIR}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 3 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 4 | UNINATIVE_URL ?= "unset" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 5 | UNINATIVE_TARBALL ?= "${BUILD_ARCH}-nativesdk-libc.tar.xz" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 6 | # Example checksums |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | #UNINATIVE_CHECKSUM[aarch64] = "dead" |
| 8 | #UNINATIVE_CHECKSUM[i686] = "dead" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 9 | #UNINATIVE_CHECKSUM[x86_64] = "dead" |
| 10 | UNINATIVE_DLDIR ?= "${DL_DIR}/uninative/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 11 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 12 | # Enabling uninative will change the following variables so they need to go the parsing white list to prevent multiple recipe parsing |
| 13 | BB_HASHCONFIG_WHITELIST += "NATIVELSBSTRING SSTATEPOSTUNPACKFUNCS BUILD_LDFLAGS" |
| 14 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 15 | addhandler uninative_event_fetchloader |
| 16 | uninative_event_fetchloader[eventmask] = "bb.event.BuildStarted" |
| 17 | |
| 18 | addhandler uninative_event_enable |
| 19 | uninative_event_enable[eventmask] = "bb.event.ConfigParsed" |
| 20 | |
| 21 | python uninative_event_fetchloader() { |
| 22 | """ |
| 23 | This event fires on the parent and will try to fetch the tarball if the |
| 24 | loader isn't already present. |
| 25 | """ |
| 26 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 27 | chksum = d.getVarFlag("UNINATIVE_CHECKSUM", d.getVar("BUILD_ARCH")) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 28 | if not chksum: |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 29 | bb.fatal("Uninative selected but not configured correctly, please set UNINATIVE_CHECKSUM[%s]" % d.getVar("BUILD_ARCH")) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 30 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 31 | loader = d.getVar("UNINATIVE_LOADER") |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 32 | loaderchksum = loader + ".chksum" |
| 33 | if os.path.exists(loader) and os.path.exists(loaderchksum): |
| 34 | with open(loaderchksum, "r") as f: |
| 35 | readchksum = f.read().strip() |
| 36 | if readchksum == chksum: |
| 37 | return |
| 38 | |
| 39 | import subprocess |
| 40 | try: |
| 41 | # Save and restore cwd as Fetch.download() does a chdir() |
| 42 | olddir = os.getcwd() |
| 43 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 44 | tarball = d.getVar("UNINATIVE_TARBALL") |
| 45 | tarballdir = os.path.join(d.getVar("UNINATIVE_DLDIR"), chksum) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 46 | tarballpath = os.path.join(tarballdir, tarball) |
| 47 | |
| 48 | if not os.path.exists(tarballpath): |
| 49 | bb.utils.mkdirhier(tarballdir) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 50 | if d.getVar("UNINATIVE_URL") == "unset": |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 51 | bb.fatal("Uninative selected but not configured, please set UNINATIVE_URL") |
| 52 | |
| 53 | localdata = bb.data.createCopy(d) |
| 54 | localdata.setVar('FILESPATH', "") |
| 55 | localdata.setVar('DL_DIR', tarballdir) |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 56 | # Our games with path manipulation of DL_DIR mean standard PREMIRRORS don't work |
| 57 | # and we can't easily put 'chksum' into the url path from a url parameter with |
| 58 | # the current fetcher url handling |
| 59 | ownmirror = d.getVar('SOURCE_MIRROR_URL') |
| 60 | if ownmirror: |
| 61 | localdata.appendVar("PREMIRRORS", " ${UNINATIVE_URL}${UNINATIVE_TARBALL} ${SOURCE_MIRROR_URL}/uninative/%s/${UNINATIVE_TARBALL}" % chksum) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 62 | |
| 63 | srcuri = d.expand("${UNINATIVE_URL}${UNINATIVE_TARBALL};sha256sum=%s" % chksum) |
| 64 | bb.note("Fetching uninative binary shim from %s" % srcuri) |
| 65 | |
| 66 | fetcher = bb.fetch2.Fetch([srcuri], localdata, cache=False) |
| 67 | fetcher.download() |
| 68 | localpath = fetcher.localpath(srcuri) |
| 69 | if localpath != tarballpath and os.path.exists(localpath) and not os.path.exists(tarballpath): |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 70 | # Follow the symlink behavior from the bitbake fetch2. |
| 71 | # This will cover the case where an existing symlink is broken |
| 72 | # as well as if there are two processes trying to create it |
| 73 | # at the same time. |
| 74 | if os.path.islink(tarballpath): |
| 75 | # Broken symbolic link |
| 76 | os.unlink(tarballpath) |
| 77 | |
| 78 | # Deal with two processes trying to make symlink at once |
| 79 | try: |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 80 | os.symlink(localpath, tarballpath) |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 81 | except FileExistsError: |
| 82 | pass |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 83 | |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 84 | # ldd output is "ldd (Ubuntu GLIBC 2.23-0ubuntu10) 2.23", extract last option from first line |
| 85 | glibcver = subprocess.check_output(["ldd", "--version"]).decode('utf-8').split('\n')[0].split()[-1] |
| 86 | if bb.utils.vercmp_string(d.getVar("UNINATIVE_MAXGLIBCVERSION"), glibcver) < 0: |
| 87 | raise RuntimeError("Your host glibc verson (%s) is newer than that in uninative (%s). Disabling uninative so that sstate is not corrupted." % (glibcver, d.getVar("UNINATIVE_MAXGLIBCVERSION"))) |
| 88 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 89 | cmd = d.expand("\ |
| 90 | mkdir -p ${UNINATIVE_STAGING_DIR}-uninative; \ |
| 91 | cd ${UNINATIVE_STAGING_DIR}-uninative; \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 92 | tar -xJf ${UNINATIVE_DLDIR}/%s/${UNINATIVE_TARBALL}; \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 93 | ${UNINATIVE_STAGING_DIR}-uninative/relocate_sdk.py \ |
| 94 | ${UNINATIVE_STAGING_DIR}-uninative/${BUILD_ARCH}-linux \ |
| 95 | ${UNINATIVE_LOADER} \ |
| 96 | ${UNINATIVE_LOADER} \ |
| 97 | ${UNINATIVE_STAGING_DIR}-uninative/${BUILD_ARCH}-linux/${bindir_native}/patchelf-uninative \ |
| 98 | ${UNINATIVE_STAGING_DIR}-uninative/${BUILD_ARCH}-linux${base_libdir_native}/libc*.so" % chksum) |
| 99 | subprocess.check_output(cmd, shell=True) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 100 | |
| 101 | with open(loaderchksum, "w") as f: |
| 102 | f.write(chksum) |
| 103 | |
| 104 | enable_uninative(d) |
| 105 | |
Brad Bishop | 0011132 | 2018-04-01 22:23:53 -0400 | [diff] [blame] | 106 | except RuntimeError as e: |
| 107 | bb.warn(str(e)) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 108 | except bb.fetch2.BBFetchException as exc: |
| 109 | bb.warn("Disabling uninative as unable to fetch uninative tarball: %s" % str(exc)) |
| 110 | bb.warn("To build your own uninative loader, please bitbake uninative-tarball and set UNINATIVE_TARBALL appropriately.") |
| 111 | except subprocess.CalledProcessError as exc: |
| 112 | bb.warn("Disabling uninative as unable to install uninative tarball: %s" % str(exc)) |
| 113 | bb.warn("To build your own uninative loader, please bitbake uninative-tarball and set UNINATIVE_TARBALL appropriately.") |
| 114 | finally: |
| 115 | os.chdir(olddir) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 116 | } |
| 117 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 118 | python uninative_event_enable() { |
| 119 | """ |
| 120 | This event handler is called in the workers and is responsible for setting |
| 121 | up uninative if a loader is found. |
| 122 | """ |
| 123 | enable_uninative(d) |
| 124 | } |
| 125 | |
| 126 | def enable_uninative(d): |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 127 | loader = d.getVar("UNINATIVE_LOADER") |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 128 | if os.path.exists(loader): |
| 129 | bb.debug(2, "Enabling uninative") |
Brad Bishop | 37a0e4d | 2017-12-04 01:01:44 -0500 | [diff] [blame] | 130 | d.setVar("NATIVELSBSTRING", "universal%s" % oe.utils.host_gcc_version(d)) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 131 | d.appendVar("SSTATEPOSTUNPACKFUNCS", " uninative_changeinterp") |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 132 | d.appendVarFlag("SSTATEPOSTUNPACKFUNCS", "vardepvalueexclude", "| uninative_changeinterp") |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 133 | d.appendVar("BUILD_LDFLAGS", " -Wl,--allow-shlib-undefined -Wl,--dynamic-linker=${UNINATIVE_LOADER}") |
| 134 | d.appendVarFlag("BUILD_LDFLAGS", "vardepvalueexclude", "| -Wl,--allow-shlib-undefined -Wl,--dynamic-linker=${UNINATIVE_LOADER}") |
| 135 | d.appendVarFlag("BUILD_LDFLAGS", "vardepsexclude", "UNINATIVE_LOADER") |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 136 | d.prependVar("PATH", "${STAGING_DIR}-uninative/${BUILD_ARCH}-linux${bindir_native}:") |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 137 | |
| 138 | python uninative_changeinterp () { |
| 139 | import subprocess |
| 140 | import stat |
| 141 | import oe.qa |
| 142 | |
| 143 | if not (bb.data.inherits_class('native', d) or bb.data.inherits_class('crosssdk', d) or bb.data.inherits_class('cross', d)): |
| 144 | return |
| 145 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 146 | sstateinst = d.getVar('SSTATE_INSTDIR') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 147 | for walkroot, dirs, files in os.walk(sstateinst): |
| 148 | for file in files: |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 149 | if file.endswith(".so") or ".so." in file: |
| 150 | continue |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 151 | f = os.path.join(walkroot, file) |
| 152 | if os.path.islink(f): |
| 153 | continue |
| 154 | s = os.stat(f) |
| 155 | if not ((s[stat.ST_MODE] & stat.S_IXUSR) or (s[stat.ST_MODE] & stat.S_IXGRP) or (s[stat.ST_MODE] & stat.S_IXOTH)): |
| 156 | continue |
| 157 | elf = oe.qa.ELFFile(f) |
| 158 | try: |
| 159 | elf.open() |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 160 | except oe.qa.NotELFFileError: |
| 161 | continue |
| 162 | if not elf.isDynamic(): |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 163 | continue |
| 164 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 165 | subprocess.check_output(("patchelf-uninative", "--set-interpreter", d.getVar("UNINATIVE_LOADER"), f), stderr=subprocess.STDOUT) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 166 | } |