Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | SUMMARY = "Utility scripts for internationalizing XML" |
| 2 | SECTION = "devel" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 5 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 6 | SRC_URI = "http://launchpad.net/${BPN}/trunk/${PV}/+download/${BP}.tar.gz \ |
| 7 | file://intltool-nowarn.patch \ |
| 8 | file://perl-522-deprecations.patch \ |
| 9 | file://remove-perl-check.patch \ |
| 10 | file://noperlcheck.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 11 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 12 | SRC_URI[md5sum] = "12e517cac2b57a0121cda351570f1e63" |
| 13 | SRC_URI[sha256sum] = "67c74d94196b153b774ab9f89b2fa6c6ba79352407037c8c14d5aeb334e959cd" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 14 | |
| 15 | UPSTREAM_CHECK_URI = "https://launchpad.net/intltool/trunk/" |
| 16 | |
| 17 | DEPENDS = "libxml-parser-perl-native" |
| 18 | RDEPENDS_${PN} = "gettext-dev libxml-parser-perl" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 19 | DEPENDS_class-native = "libxml-parser-perl-native gettext-native" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 20 | |
| 21 | inherit autotools pkgconfig perlnative |
| 22 | |
| 23 | export PERL = "${bindir}/env perl" |
| 24 | PERL_class-native = "/usr/bin/env nativeperl" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 25 | PERL_class-nativesdk = "/usr/bin/env perl" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 26 | |
| 27 | # gettext is assumed to exist on the host |
| 28 | RDEPENDS_${PN}_class-native = "libxml-parser-perl-native" |
| 29 | RRECOMMENDS_${PN} = "perl-modules" |
| 30 | RRECOMMENDS_${PN}_class-native = "" |
| 31 | |
| 32 | FILES_${PN}-dev = "" |
| 33 | FILES_${PN} += "${datadir}/aclocal" |
| 34 | |
| 35 | INSANE_SKIP_${PN} += "dev-deps" |
| 36 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 37 | BBCLASSEXTEND = "native nativesdk" |