Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "ITS Tool allows you to translate your XML documents with PO files" |
| 2 | DESCRIPTION = "It extracts messages from XML files and outputs PO template \ |
| 3 | files, then merges translations from MO files to create translated \ |
| 4 | XML files. It determines what to translate and how to chunk it into \ |
| 5 | messages using the W3C Internationalization Tag Set (ITS). " |
| 6 | HOMEPAGE = "http://itstool.org/" |
| 7 | LICENSE = "GPLv3" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=59c57b95fd7d0e9e238ebbc7ad47c5a5" |
| 9 | |
| 10 | inherit autotools python3native |
| 11 | |
| 12 | DEPENDS = "libxml2-native" |
| 13 | |
| 14 | SRC_URI = "http://files.itstool.org/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 15 | " |
| 16 | SRC_URI:append:class-native = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch" |
| 17 | SRC_URI:append:class-nativesdk = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch" |
| 18 | SRC_URI:append:class-target = " file://0002-Don-t-use-build-time-hardcoded-python-binary-path.patch" |
| 19 | |
| 20 | SRC_URI[sha256sum] = "6b9a7cd29a12bb95598f5750e8763cee78836a1a207f85b74d8b3275b27e87ca" |
| 21 | |
| 22 | BBCLASSEXTEND = "native nativesdk" |
| 23 | |
| 24 | RDEPENDS:${PN} += "libxml2-python" |