Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Utilities for interacting with PyPI" |
| 2 | HOMEPAGE = "https://twine.readthedocs.io/" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a3d1106b253a8d50dd82a4202a045b4c" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "28460a3db6b4532bde6a5db6755cf2dce6c5020bada8a641bb2c5c7a9b1f35b8" |
| 7 | |
| 8 | inherit pypi setuptools3 |
| 9 | |
| 10 | DEPENDS += "\ |
| 11 | ${PYTHON_PN}-setuptools-scm-native \ |
| 12 | " |
| 13 | |
| 14 | RDEPENDS:${PN} += " \ |
| 15 | ${PYTHON_PN}-importlib-metadata \ |
| 16 | " |
| 17 | |
| 18 | do_compile:prepend() { |
| 19 | echo "from setuptools import setup" > ${S}/setup.py |
| 20 | echo "setup()" >> ${S}/setup.py |
| 21 | } |
| 22 | |
| 23 | BBCLASSEXTEND = "native" |