Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | LICENSE = "GPLv3+" |
| 2 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 3 | |
| 4 | require diffutils.inc |
| 5 | |
| 6 | SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.xz \ |
| 7 | file://run-ptest \ |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 8 | file://0001-Skip-strip-trailing-cr-test-case.patch \ |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 9 | " |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "a6bdd7d1b31266d11c4f4de6c1b748d4607ab0231af5188fc2533d0ae2438fec" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | |
| 13 | EXTRA_OECONF += "ac_cv_path_PR_PROGRAM=${bindir}/pr --without-libsigsegv-prefix" |
| 14 | |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 15 | # latest gnulib is no longer able to handle this - I dare not try to fix that maze of abstractions and generators |
| 16 | CFLAGS:mingw32 = " -DSA_RESTART=0" |
| 17 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | # Fix "Argument list too long" error when len(TMPDIR) = 410 |
| 19 | acpaths = "-I ./m4" |
| 20 | |
| 21 | inherit ptest |
| 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | RDEPENDS:${PN}-ptest += "make perl" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | |
| 25 | do_install_ptest() { |
| 26 | t=${D}${PTEST_PATH} |
| 27 | install -D ${S}/build-aux/test-driver $t/build-aux/test-driver |
| 28 | cp -r ${S}/tests $t/ |
| 29 | install ${B}/tests/Makefile $t/tests/ |
| 30 | sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \ |
| 31 | -e 's|${DEBUG_PREFIX_MAP}||g' \ |
| 32 | -e 's:${HOSTTOOLS_DIR}/::g' \ |
| 33 | -e 's:${RECIPE_SYSROOT_NATIVE}::g' \ |
| 34 | -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \ |
| 35 | -e 's|^Makefile:|_Makefile:|' \ |
| 36 | -e 's|bash|sh|' \ |
| 37 | -e 's|^top_srcdir = \(.*\)|top_srcdir = ..\/|' \ |
| 38 | -e 's|^srcdir = \(.*\)|srcdir = .|' \ |
| 39 | -e 's|"`$(built_programs)`"|diff|' \ |
| 40 | -e 's|gawk|awk|g' \ |
| 41 | -i $t/tests/Makefile |
| 42 | } |