Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Line-oriented text editor" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/ed/" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 3 | DESCRIPTION = "GNU ed is a line-oriented text editor. It is used to create, display, modify and otherwise manipulate text files, both interactively and via shell scripts. A restricted version of ed, red, can only edit files in the current directory and cannot execute shell commands." |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 4 | |
| 5 | LICENSE = "GPLv3+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=0c7051aef9219dc7237f206c5c4179a7 \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 7 | file://ed.h;endline=20;md5=b72aa5eaafef318c6bfc37f858469113 \ |
| 8 | file://main.c;endline=17;md5=2c93e24f4db3528a00a24c7df5618e41 \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | " |
| 10 | |
| 11 | SECTION = "base" |
| 12 | |
| 13 | CVE_PRODUCT = "gnu:ed" |
| 14 | |
| 15 | # LSB states that ed should be in /bin/ |
| 16 | bindir = "${base_bindir}" |
| 17 | |
| 18 | # Upstream regularly removes previous releases from https://ftp.gnu.org/gnu/ed/ |
| 19 | SRC_URI = "${GNU_MIRROR}/ed/${BP}.tar.lz" |
| 20 | UPSTREAM_CHECK_URI = "${GNU_MIRROR}/ed/" |
| 21 | |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 22 | SRC_URI[sha256sum] = "71de39883c25b6fab44add80635382a10c9bf154515b94729f4a6529ddcc5e54" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | |
| 24 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 25 | |
| 26 | inherit texinfo |
| 27 | |
| 28 | do_configure() { |
| 29 | ${S}/configure |
| 30 | } |
| 31 | |
| 32 | do_install() { |
| 33 | oe_runmake 'DESTDIR=${D}' install |
| 34 | # Info dir listing isn't interesting at this point so remove it if it exists. |
| 35 | if [ -e "${D}${infodir}/dir" ]; then |
| 36 | rm -f ${D}${infodir}/dir |
| 37 | fi |
| 38 | } |