Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Implements a XML/HTML/XHTML Markup safe string for Python" |
| 2 | HOMEPAGE = "http://github.com/mitsuhiko/markupsafe" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "7f91197cc9e48f989d12e4e6fbc46495c446636dfc81b9ccf50bb0ec74b91d4b" |
| 7 | |
| 8 | PYPI_PACKAGE = "MarkupSafe" |
| 9 | inherit pypi setuptools3 |
| 10 | inherit ${@bb.utils.filter('DISTRO_FEATURES', 'ptest', d)} |
| 11 | |
| 12 | RDEPENDS:${PN} += "${PYTHON_PN}-stringold" |
| 13 | |
| 14 | BBCLASSEXTEND = "native nativesdk" |
| 15 | |
| 16 | SRC_URI += " \ |
| 17 | file://run-ptest \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS:${PN}-ptest += " \ |
| 21 | ${PYTHON_PN}-pytest \ |
| 22 | " |
| 23 | |
| 24 | do_install_ptest() { |
| 25 | install -d ${D}${PTEST_PATH}/tests |
| 26 | cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 27 | } |