Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Arbitrary precision calculator language" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/bc/bc.html" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 3 | DESCRIPTION = "bc is an arbitrary precision numeric processing language. Syntax is similar to C, but differs in many substantial areas. It supports interactive execution of statements." |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 4 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 5 | LICENSE = "GPL-3.0-or-later" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| 7 | file://COPYING.LIB;md5=6a6a8e020838b23406c81b19c1d46df6 \ |
| 8 | file://bc/bcdefs.h;endline=17;md5=4295c06df9e833519a342f7b5d43db06 \ |
| 9 | file://dc/dc.h;endline=18;md5=36b8c600b63ee8c3aeade2764f6b2a4b \ |
| 10 | file://lib/number.c;endline=20;md5=cf43068cc88f837731dc53240456cfaf" |
| 11 | |
| 12 | SECTION = "base" |
| 13 | DEPENDS = "flex-native" |
| 14 | |
| 15 | SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \ |
| 16 | file://no-gen-libmath.patch \ |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 17 | file://libmath.h \ |
| 18 | file://0001-dc-fix-exit-code-of-q-command.patch" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | SRC_URI[md5sum] = "cda93857418655ea43590736fc3ca9fc" |
| 20 | SRC_URI[sha256sum] = "62adfca89b0a1c0164c2cdca59ca210c1d44c3ffc46daf9931cf4942664cb02a" |
| 21 | |
| 22 | inherit autotools texinfo update-alternatives |
| 23 | |
| 24 | PACKAGECONFIG ??= "readline" |
| 25 | PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline" |
| 26 | PACKAGECONFIG[libedit] = "--with-libedit,--without-libedit,libedit" |
| 27 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | do_compile:prepend() { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | cp -f ${WORKDIR}/libmath.h ${B}/bc/libmath.h |
| 30 | } |
| 31 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | ALTERNATIVE:${PN} = "bc dc" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 33 | ALTERNATIVE_PRIORITY = "100" |
| 34 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 35 | BBCLASSEXTEND = "native" |