Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Modern C++ network programming libraries." |
| 2 | |
| 3 | # This library provides general purpose network functionality such as |
| 4 | # socket communication to agent libraries. It was designed to be merged |
| 5 | # into boost at some point and follows similar header library approach |
| 6 | # for most functionality. |
| 7 | |
| 8 | SECTION = "libs" |
| 9 | LICENSE = "BSL-1.0 & MIT & Python-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c" |
| 11 | |
| 12 | SRC_URI = "\ |
| 13 | git://github.com/cpp-netlib/cpp-netlib.git;protocol=https;branch=0.13-release \ |
| 14 | " |
| 15 | SRC_URI[sha256sum] = "0b9255bb0668d89867a1f367d770f12d7038db4f5b6111774ef032f669cccad4" |
| 16 | |
| 17 | SRCREV = "ca95f04d140acf619892ee02a82e930dd91ff7d4" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit cmake pkgconfig |
| 22 | |
| 23 | DEPENDS = "zlib boost openssl" |
| 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | EXTRA_OECMAKE:append = " -DCPP-NETLIB_BUILD_TESTS=OFF -DCPP-NETLIB_BUILD_EXAMPLES=OFF" |
Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 26 | |