blob: ca6f9ba3faad4eb759040b3ac6169de61580be33 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "API for managing information about operating systems, hypervisors and the (virtual) hardware devices."
2HOMEPAGE = "https://libosinfo.org"
3
4LICENSE = "LGPL-2.1-only & GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=2b0e9926530c269f5ae95560370195af"
6LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
7
8SRC_URI = " \
9 git://gitlab.com/libosinfo/libosinfo.git;branch=main;protocol=https \
10 file://0001-meson.build-allow-crosscompiling-gir.patch \
11"
12
13SRCREV = "ca9dd5b810dc04ea38048ae9be491654c8596ef9"
14
15S = "${WORKDIR}/git"
16
17inherit meson pkgconfig gtk-doc gobject-introspection vala
18
19DEPENDS = "glib-2.0 libsoup libxslt"
20
21VALA_MESON_OPTION = 'enable-vala'
22VALA_MESON_ENABLE_FLAG = 'enabled'
23VALA_MESON_DISABLE_FLAG = 'disabled'
24GIR_MESON_OPTION = "enable-introspection"
25GIR_MESON_ENABLE_FLAG = 'enabled'
26GIR_MESON_DISABLE_FLAG = 'disabled'
27GTKDOC_MESON_OPTION = "enable-gtk-doc"
28
29EXTRA_OEMESON += " \
30 -Dwith-pci-ids-path=${datadir}/pci.ids \
31 -Dwith-usb-ids-path=${datadir}/usb.ids \
32"
33
34RDEPENDS:${PN} = "pciutils-ids usbids"