Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Simple DirectMedia Layer mixer library" |
| 2 | SECTION = "libs" |
| 3 | DEPENDS = "virtual/libsdl flac libmikmod libvorbis" |
| 4 | LICENSE = "Zlib" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=a37a47a0e579e461474cd03b9e05199d" |
| 6 | |
| 7 | SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz \ |
| 8 | file://configure.patch \ |
| 9 | " |
| 10 | |
| 11 | SRC_URI[md5sum] = "e03ff73d77a55e3572ad0217131dc4a1" |
| 12 | SRC_URI[sha256sum] = "1644308279a975799049e4826af2cfc787cad2abb11aa14562e402521f86992a" |
| 13 | |
| 14 | S = "${WORKDIR}/SDL_mixer-${PV}" |
| 15 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 16 | inherit autotools-brokensep pkgconfig |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 17 | |
| 18 | EXTRA_AUTORECONF += "--include=acinclude" |
| 19 | EXTRA_OECONF = "--disable-music-mp3 --enable-music-ogg --enable-music-ogg-tremor LIBS=-L${STAGING_LIBDIR}" |
| 20 | |
| 21 | PACKAGECONFIG[mad] = "--enable-music-mp3-mad-gpl,--disable-music-mp3-mad-gpl,libmad" |
| 22 | |
| 23 | do_configure () { |
| 24 | # Remove old libtool macros. |
| 25 | MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4" |
| 26 | for i in ${MACROS}; do |
| 27 | rm -f acinclude/$i |
| 28 | done |
| 29 | cp build-scripts/* . || true |
| 30 | rm -rf build-scripts/ |
| 31 | export SYSROOT=$PKG_CONFIG_SYSROOT_DIR |
| 32 | |
| 33 | autotools_do_configure |
| 34 | |
| 35 | rm config.log |
| 36 | for i in $(find -name "Makefile") ; do |
| 37 | sed -i -e 's:-L/usr/lib:-L${STAGING_LIBDIR}:g' $i |
| 38 | done |
| 39 | } |