blob: 06ab0dfeb432d76056faaaef3442f61db48af2a9 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Easily themable notification daemon with transparency effects"
2HOMEPAGE = "http://goodies.xfce.org/projects/applications/xfce4-notifyd"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5DEPENDS = " \
6 dbus \
7 dbus-glib \
8 libnotify \
9 libxfce4util \
10 libxfce4ui \
11 xfconf \
12 xfce4-panel \
13"
14
15inherit xfce-app
16
17SRC_URI[md5sum] = "9614d4f7c0790e8ab24e55896a44a8ac"
18SRC_URI[sha256sum] = "090571acf94c423003426cb779fb23e8545c68bab6485563b589c7def8a21b55"
19
20# Avoid trouble with other desktops e.g KDE which also ships dbus service named
21# org.freedesktop.Notifications
22EXTRA_OECONF = "--disable-dbus-start-daemon"
23
24do_compile_prepend() {
25 mkdir -p xfce4-notifyd xfce4-notifyd-config
26}
27
28FILES_${PN} += " \
29 ${systemd_user_unitdir} \
30 ${datadir}/xfce4 \
31 ${datadir}/themes \
32 ${datadir}/dbus-1 \
33 ${libdir}/xfce4 \
34"