blob: b5c8573296e78ab1ecdd9b5fc7585c5c2522a4a1 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001DESCRIPTION = "A modern, C++-native, header-only, test framework for unit-tests, \
2TDD and BDD - using C++11, C++14, C++17 and later."
3AUTHOR = "Phil Nash, Martin Horenovsky and others"
4HOMEPAGE = "https://github.com/catchorg/Catch2"
5LICENSE = "BSL-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
7
8SRC_URI = "git://github.com/catchorg/Catch2.git \
9 "
10# v2.7.2
11SRCREV = "7c37501b070c0e9ea9cdedbeac2059f0a6b0a8ab"
12
13S = "${WORKDIR}/git"
14
15inherit cmake python3native
16
17do_install_append() {
18 rm ${D}${datadir}/Catch2/lldbinit
19 rm ${D}${datadir}/Catch2/gdbinit
20 rmdir ${D}${datadir}/Catch2/
21}
22# Header-only library
23RDEPENDS_${PN}-dev = ""
24RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"