Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | DESCRIPTION = "A modern, C++-native, header-only, test framework for unit-tests, \ |
| 2 | TDD and BDD - using C++11, C++14, C++17 and later." |
| 3 | AUTHOR = "Phil Nash, Martin Horenovsky and others" |
| 4 | HOMEPAGE = "https://github.com/catchorg/Catch2" |
| 5 | LICENSE = "BSL-1.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c" |
| 7 | |
| 8 | SRC_URI = "git://github.com/catchorg/Catch2.git \ |
| 9 | " |
| 10 | # v2.7.2 |
| 11 | SRCREV = "7c37501b070c0e9ea9cdedbeac2059f0a6b0a8ab" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit cmake python3native |
| 16 | |
| 17 | do_install_append() { |
| 18 | rm ${D}${datadir}/Catch2/lldbinit |
| 19 | rm ${D}${datadir}/Catch2/gdbinit |
| 20 | rmdir ${D}${datadir}/Catch2/ |
| 21 | } |
| 22 | # Header-only library |
| 23 | RDEPENDS_${PN}-dev = "" |
| 24 | RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})" |