Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Program for creating simple man pages" |
| 2 | SECTION = "devel" |
| 3 | LICENSE = "GPLv3" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 5 | DEPENDS = "autoconf-native automake-native" |
| 6 | |
| 7 | SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz" |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 8 | SRC_URI[md5sum] = "dd322adcaede5bd5eaed075ff8971bc1" |
| 9 | SRC_URI[sha256sum] = "5985b257f86304c8791842c0c807a37541d0d6807ee973000cf8a3fe6ad47b88" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 10 | |
| 11 | inherit autotools native |
| 12 | |
| 13 | EXTRA_OECONF = "--disable-nls" |
| 14 | |
| 15 | # We don't want to reconfigure things as it would require 'perlnative' to be |
| 16 | # used. |
| 17 | do_configure() { |
| 18 | oe_runconf |
| 19 | } |
| 20 | |
| 21 | do_install_append () { |
| 22 | # Make sure we use /usr/bin/env perl |
| 23 | sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man |
| 24 | } |