Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Very simple session manager for X" |
| 2 | HOMEPAGE = "http://www.yoctoproject.org" |
| 3 | BUGTRACKER = "http://bugzilla.pokylinux.org" |
| 4 | |
| 5 | PR = "r4" |
| 6 | |
| 7 | LICENSE = "GPLv2" |
| 8 | LIC_FILES_CHKSUM = "file://mini-x-session;endline=5;md5=b6430bffbcf05f9760e72938826b7487" |
| 9 | |
| 10 | SECTION = "x11" |
| 11 | RCONFLICTS_${PN} = "matchbox-common" |
| 12 | |
| 13 | SRC_URI = "file://mini-x-session" |
| 14 | S = "${WORKDIR}" |
| 15 | |
| 16 | RDEPENDS_${PN} = "sudo" |
| 17 | |
| 18 | inherit update-alternatives |
| 19 | |
| 20 | ALTERNATIVE_${PN} = "x-session-manager" |
| 21 | ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/mini-x-session" |
| 22 | ALTERNATIVE_PRIORITY = "50" |
| 23 | |
| 24 | do_install() { |
| 25 | install -d ${D}/${bindir} |
| 26 | install -m 0755 ${S}/mini-x-session ${D}/${bindir} |
| 27 | } |