Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "SM: Session Management library" |
| 2 | |
| 3 | DESCRIPTION = "The Session Management Library (SMlib) is a low-level \"C\" \ |
| 4 | language interface to XSMP. The purpose of the X Session Management \ |
| 5 | Protocol (XSMP) is to provide a uniform mechanism for users to save and \ |
| 6 | restore their sessions. A session is a group of clients, each of which \ |
| 7 | has a particular state." |
| 8 | |
| 9 | require xorg-lib-common.inc |
| 10 | |
| 11 | LICENSE = "MIT-style" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=c0fb37f44e02bdbde80546024400728d" |
| 13 | |
| 14 | DEPENDS += "libice xorgproto xtrans" |
| 15 | |
| 16 | # libSM can work without libuuid, we explicitly disable it to break the following circular dependency |
| 17 | # when DISTRO_FEATURES contains 'systemd' and 'x11'. |
| 18 | # systemd -> dbus -> libsm -> util-linux -> systemd |
| 19 | EXTRA_OECONF += "--without-libuuid" |
| 20 | |
| 21 | PE = "1" |
| 22 | |
| 23 | XORG_PN = "libSM" |
| 24 | |
| 25 | SRC_URI[md5sum] = "87c7fad1c1813517979184c8ccd76628" |
| 26 | SRC_URI[sha256sum] = "2d264499dcb05f56438dee12a1b4b71d76736ce7ba7aa6efbf15ebb113769cbb" |
| 27 | |
| 28 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
| 29 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |