Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Xlib: C Language X Interface library" |
| 2 | |
| 3 | DESCRIPTION = "This package provides a client interface to the X Window \ |
| 4 | System, otherwise known as 'Xlib'. It provides a complete API for the \ |
| 5 | basic functions of the window system." |
| 6 | |
| 7 | require xorg-lib-common.inc |
| 8 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | FILESEXTRAPATHS =. "${FILE_DIRNAME}/libx11:" |
| 10 | |
| 11 | PE = "1" |
| 12 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 13 | SRC_URI += "file://Fix-hanging-issue-in-_XReply.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | file://disable_tests.patch \ |
| 15 | file://libx11-whitespace.patch" |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 16 | |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 17 | SRC_URI[md5sum] = "55adbfb6d4370ecac5e70598c4e7eed2" |
| 18 | SRC_URI[sha256sum] = "9cc7e8d000d6193fa5af580d50d689380b8287052270f5bb26a5fb6b58b2bed1" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 19 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 20 | PROVIDES = "virtual/libx11" |
| 21 | |
| 22 | XORG_PN = "libX11" |
| 23 | LICENSE = "MIT & MIT-style & BSD" |
| 24 | LIC_FILES_CHKSUM = "file://COPYING;md5=172255dee66bb0151435b2d5d709fcf7" |
| 25 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 26 | DEPENDS += "xorgproto xtrans libxcb" |
| 27 | DEPENDS += "xorgproto-native" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 28 | |
| 29 | EXTRA_OECONF += "--with-keysymdefdir=${STAGING_INCDIR}/X11/ --disable-xf86bigfont" |
| 30 | EXTRA_OEMAKE += 'CWARNFLAGS=""' |
| 31 | |
| 32 | PACKAGECONFIG ??= "xcms" |
| 33 | PACKAGECONFIG[xcms] = "--enable-xcms,--disable-xcms" |
| 34 | |
| 35 | # src/util/makekeys is built natively but needs -D_GNU_SOURCE defined. |
| 36 | CPPFLAGS_FOR_BUILD += "-D_GNU_SOURCE" |
| 37 | |
| 38 | PACKAGES =+ "${PN}-xcb" |
| 39 | |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 40 | inherit gettext |
| 41 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 42 | FILES_${PN} += "${datadir}/X11/XKeysymDB ${datadir}/X11/XErrorDB ${datadir}/X11/Xcms.txt" |
| 43 | FILES_${PN}-xcb += "${libdir}/libX11-xcb.so.*" |
| 44 | FILES_${PN}-locale += "${datadir}/X11/locale ${libdir}/X11/locale" |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 45 | |
| 46 | BBCLASSEXTEND = "native nativesdk" |