Thang Q. Nguyen | 8b96ab5 | 2023-04-15 11:10:42 +0700 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC Boot Progress Handling Service" |
| 2 | DESCRIPTION = "Phosphor OpenBMC Altra Boot Progress Handling Daemon" |
Thang Q. Nguyen | 7542929 | 2021-07-06 08:49:17 +0000 | [diff] [blame] | 3 | |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 7 | |
| 8 | inherit systemd |
| 9 | inherit obmc-phosphor-systemd |
| 10 | |
| 11 | DEPENDS += "systemd" |
| 12 | RDEPENDS:${PN} += "libsystemd" |
| 13 | RDEPENDS:${PN} += "bash" |
| 14 | |
| 15 | SRC_URI = " \ |
| 16 | file://ampere_boot_progress.sh \ |
Thang Q. Nguyen | 8b96ab5 | 2023-04-15 11:10:42 +0700 | [diff] [blame] | 17 | file://dimm_train_fail_log.sh \ |
Thang Q. Nguyen | 7542929 | 2021-07-06 08:49:17 +0000 | [diff] [blame] | 18 | " |
| 19 | |
| 20 | SYSTEMD_PACKAGES = "${PN}" |
| 21 | |
| 22 | HOST_ON_RESET_HOSTTMPL = "ampere-boot-progress.service" |
| 23 | HOST_ON_RESET_HOSTINSTMPL = "ampere-boot-progress.service" |
| 24 | HOST_ON_RESET_HOSTTGTFMT = "obmc-host-already-on@{0}.target" |
| 25 | HOST_ON_RESET_HOSTFMT = "../${HOST_ON_RESET_HOSTTMPL}:${HOST_ON_RESET_HOSTTGTFMT}.requires/${HOST_ON_RESET_HOSTINSTMPL}" |
| 26 | SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'HOST_ON_RESET_HOSTFMT', 'OBMC_HOST_INSTANCES')}" |
| 27 | |
| 28 | SYSTEMD_SERVICE:${PN} += "${HOST_ON_RESET_HOSTTMPL}" |
| 29 | |
| 30 | do_install () { |
| 31 | install -d ${D}${sbindir} |
| 32 | install -m 0755 ${WORKDIR}/ampere_boot_progress.sh ${D}${sbindir}/ |
Thang Q. Nguyen | 8b96ab5 | 2023-04-15 11:10:42 +0700 | [diff] [blame] | 33 | install -m 0755 ${WORKDIR}/dimm_train_fail_log.sh ${D}${sbindir}/ |
Thang Q. Nguyen | 7542929 | 2021-07-06 08:49:17 +0000 | [diff] [blame] | 34 | } |
| 35 | |