Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | DESCRIPTION = "A python module for system storage configuration" |
| 2 | HOMEPAGE = "http://fedoraproject.org/wiki/blivet" |
| 3 | LICENSE = "LGPL-2.0-or-later" |
| 4 | SECTION = "devel/python" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | SRC_URI += "\ |
| 9 | file://0002-run_program-support-timeout.patch \ |
| 10 | file://0003-support-infinit-timeout.patch \ |
| 11 | file://0004-fix-new.roots-object-is-not-iterable.patch \ |
| 12 | file://0005-fix-incorrect-timeout-while-system-time-changed.patch \ |
| 13 | file://0006-tweak-btrfs-packages.patch \ |
| 14 | file://0007-invoking-mount-with-infinite-timeout.patch \ |
| 15 | file://0008-use-oe-variable-to-replace-hardcoded-dir.patch \ |
| 16 | file://0009-invoking-fsck-with-infinite-timeout.patch \ |
| 17 | file://0010-invoking-mkfs-with-infinite-timeout.patch \ |
| 18 | file://0011-invoking-dd-with-infinite-timeout.patch \ |
| 19 | " |
| 20 | SRC_URI[sha256sum] = "1b05b77f3ee35d82c7a577a168c9ba0204d3e9a87eb1975e5f9af47700eeff48" |
| 21 | |
| 22 | inherit pypi features_check systemd setuptools3_legacy |
| 23 | |
| 24 | REQUIRED_DISTRO_FEATURES = "systemd" |
| 25 | |
| 26 | RDEPENDS:${PN} += "python3-pykickstart python3-pyudev \ |
| 27 | parted python3-pyparted multipath-tools \ |
| 28 | lsof cryptsetup libblockdev \ |
| 29 | libbytesize \ |
| 30 | " |
| 31 | |
| 32 | FILES:${PN} += " \ |
| 33 | ${datadir}/dbus-1/system-services \ |
| 34 | " |
| 35 | |
| 36 | SYSTEMD_AUTO_ENABLE = "disable" |
| 37 | SYSTEMD_SERVICE:${PN} = "blivet.service" |