Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 1 | SUMMARY = "OpenPOWER processor control services installation" |
| 2 | PR = "r1" |
| 3 | |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | inherit allarch |
| 8 | |
Adriana Kobylak | 8c6707f | 2021-08-06 17:35:36 +0000 | [diff] [blame] | 9 | RDEPENDS:${PN} += "op-proc-control" |
| 10 | RDEPENDS:${PN} += "phosphor-state-manager-obmc-targets" |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 11 | |
Adriana Kobylak | 8c6707f | 2021-08-06 17:35:36 +0000 | [diff] [blame] | 12 | ALLOW_EMPTY:${PN} = "1" |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 13 | |
Adriana Kobylak | 8c6707f | 2021-08-06 17:35:36 +0000 | [diff] [blame] | 14 | pkg_postinst:${PN}() { |
Andrew Geissler | 55bd449 | 2020-03-31 13:43:46 -0500 | [diff] [blame] | 15 | mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 16 | mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires |
Dhruvaraj Subhashchandran | c8aa6a1 | 2020-03-09 13:04:32 -0500 | [diff] [blame] | 17 | mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires |
Andrew Geissler | b9b3a4a | 2023-05-12 14:10:34 -0500 | [diff] [blame] | 18 | mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants |
Dhruvaraj Subhashchandran | c8aa6a1 | 2020-03-09 13:04:32 -0500 | [diff] [blame] | 19 | mkdir -p $D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires |
Andrew Geissler | f95063e | 2020-04-14 15:08:43 -0500 | [diff] [blame] | 20 | mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires |
Andrew Geissler | c3f1beb | 2020-12-09 15:05:02 -0600 | [diff] [blame] | 21 | mkdir -p $D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 22 | |
Andrew Geissler | 55bd449 | 2020-03-31 13:43:46 -0500 | [diff] [blame] | 23 | LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service" |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 24 | TARGET="../op-stop-instructions@.service" |
| 25 | ln -s $TARGET $LINK |
| 26 | |
Andrew Geissler | c3f1beb | 2020-12-09 15:05:02 -0600 | [diff] [blame] | 27 | LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/op-stop-instructions@0.service" |
| 28 | TARGET="../op-stop-instructions@.service" |
| 29 | ln -s $TARGET $LINK |
| 30 | |
Andrew Geissler | f95063e | 2020-04-14 15:08:43 -0500 | [diff] [blame] | 31 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service" |
| 32 | TARGET="../op-cfam-reset.service" |
| 33 | ln -s $TARGET $LINK |
| 34 | |
Andrew Geissler | b9b3a4a | 2023-05-12 14:10:34 -0500 | [diff] [blame] | 35 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/xyz.openbmc_project.Control.Host.NMI.service" |
| 36 | TARGET="../xyz.openbmc_project.Control.Host.NMI.service" |
| 37 | ln -s $TARGET $LINK |
| 38 | |
Andrew Geissler | f95063e | 2020-04-14 15:08:43 -0500 | [diff] [blame] | 39 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service" |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 40 | TARGET="../op-cfam-reset.service" |
| 41 | ln -s $TARGET $LINK |
Andrew Geissler | 4e174d1 | 2020-02-26 14:11:53 -0600 | [diff] [blame] | 42 | |
| 43 | # Only install cfam override if p9 system |
| 44 | if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then |
| 45 | mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires |
| 46 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service" |
| 47 | TARGET="../cfam_override@.service" |
| 48 | ln -s $TARGET $LINK |
| 49 | fi |
Dhruvaraj Subhashchandran | c8aa6a1 | 2020-03-09 13:04:32 -0500 | [diff] [blame] | 50 | |
| 51 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service" |
| 52 | TARGET="../op-continue-mpreboot@.service" |
| 53 | ln -s $TARGET $LINK |
| 54 | |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 55 | # Only install certain units if phal enabled |
Patrick Williams | 8c561ee | 2021-10-22 14:20:12 -0500 | [diff] [blame] | 56 | if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" = phal ]; then |
Andrew Geissler | f158d90 | 2022-04-08 16:24:35 -0500 | [diff] [blame] | 57 | LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-clear-sys-dump-active@0.service" |
| 58 | TARGET="../op-clear-sys-dump-active@.service" |
| 59 | ln -s $TARGET $LINK |
| 60 | |
| 61 | mkdir -p $D$systemd_system_unitdir/multi-user.target.wants |
| 62 | LINK="$D$systemd_system_unitdir/multi-user.target.wants/op-clear-sys-dump-active@0.service" |
| 63 | TARGET="../op-clear-sys-dump-active@.service" |
| 64 | ln -s $TARGET $LINK |
| 65 | |
Ramesh Iyyar | d6d9b54 | 2020-09-17 10:02:08 -0500 | [diff] [blame] | 66 | mkdir -p $D$systemd_system_unitdir/obmc-host-start@0.target.requires |
| 67 | LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service" |
| 68 | TARGET="../phal-reinit-devtree.service" |
| 69 | ln -s $TARGET $LINK |
Chirag Sharma | 5ec16a3 | 2020-12-11 03:45:15 -0600 | [diff] [blame] | 70 | |
| 71 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service" |
| 72 | TARGET="../proc-pre-poweroff@.service" |
| 73 | ln -s $TARGET $LINK |
Andrew Geissler | 4d2fd8d | 2021-06-24 15:28:47 -0500 | [diff] [blame] | 74 | |
| 75 | LINK="$D$systemd_system_unitdir/obmc-host-reset@0.target.requires/op-reset-host-check@0.service" |
| 76 | TARGET="../op-reset-host-check@.service" |
| 77 | ln -s $TARGET $LINK |
Jayanth Othayoth | ad68ba3 | 2021-07-30 06:35:44 -0500 | [diff] [blame] | 78 | |
Jayanth Othayoth | ad68ba3 | 2021-07-30 06:35:44 -0500 | [diff] [blame] | 79 | LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service" |
| 80 | TARGET="../phal-import-devtree@.service" |
| 81 | ln -s $TARGET $LINK |
Jayanth Othayoth | ce7dbec | 2021-07-30 06:46:57 -0500 | [diff] [blame] | 82 | |
| 83 | mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants |
| 84 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/phal-export-devtree@0.service" |
| 85 | TARGET="../phal-export-devtree@.service" |
| 86 | ln -s $TARGET $LINK |
Ramesh Iyyar | d0aedb9 | 2022-02-24 03:35:40 -0600 | [diff] [blame] | 87 | |
| 88 | mkdir -p $D$systemd_system_unitdir/obmc-host-start@0.target.wants |
| 89 | LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.wants/phal-create-boottime-guard-indicator.service" |
| 90 | TARGET="../phal-create-boottime-guard-indicator.service" |
| 91 | ln -s $TARGET $LINK |
| 92 | LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/phal-create-boottime-guard-indicator.service" |
| 93 | ln -s $TARGET $LINK |
Jayanth Othayoth | 633a9cc | 2022-09-12 06:23:45 -0500 | [diff] [blame] | 94 | |
| 95 | mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.wants |
| 96 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/op-clock-data-logger@0.service" |
| 97 | TARGET="../op-clock-data-logger@.service" |
| 98 | ln -s $TARGET $LINK |
Andrew Geissler | b9b3a4a | 2023-05-12 14:10:34 -0500 | [diff] [blame] | 99 | |
| 100 | mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.wants |
| 101 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.wants/set-spi-mux.service" |
| 102 | TARGET="../set-spi-mux.service" |
| 103 | ln -s $TARGET $LINK |
Jayanth Othayoth | ad68ba3 | 2021-07-30 06:35:44 -0500 | [diff] [blame] | 104 | fi |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 105 | |
Andrew Geissler | aa25e2c | 2021-02-01 14:14:25 -0600 | [diff] [blame] | 106 | # If the memory preserving reboot feature is enabled, set it up |
| 107 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'mpreboot', d)}" = mpreboot ]; then |
| 108 | # on mpreboot systems, obmc-host-crash@.target is used for mpreboot |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 109 | mkdir -p $D$systemd_system_unitdir/obmc-host-crash@0.target.requires |
| 110 | LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-force-warm-reboot@0.target" |
| 111 | TARGET="../obmc-host-force-warm-reboot@.target" |
| 112 | ln -s $TARGET $LINK |
| 113 | |
| 114 | LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/op-enter-mpreboot@0.service" |
| 115 | TARGET="../op-enter-mpreboot@.service" |
| 116 | ln -s $TARGET $LINK |
| 117 | |
Andrew Geissler | aa25e2c | 2021-02-01 14:14:25 -0600 | [diff] [blame] | 118 | # ensure diagnostic mode is shown for MPREBOOT |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 119 | LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-diagnostic-mode@0.target" |
| 120 | TARGET="../obmc-host-diagnostic-mode@.target" |
| 121 | ln -s $TARGET $LINK |
| 122 | else |
Andrew Geissler | aa25e2c | 2021-02-01 14:14:25 -0600 | [diff] [blame] | 123 | # If not a mpreboot system, default to quiesce target in crash target to support |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 124 | # older system designs like witherspoon |
| 125 | mkdir -p $D$systemd_system_unitdir/obmc-host-crash@0.target.wants |
| 126 | LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.wants/obmc-host-quiesce@0.target" |
| 127 | TARGET="../obmc-host-quiesce@.target" |
| 128 | ln -s $TARGET $LINK |
Ramesh Iyyar | d6d9b54 | 2020-09-17 10:02:08 -0500 | [diff] [blame] | 129 | fi |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 130 | } |
| 131 | |
Adriana Kobylak | 8c6707f | 2021-08-06 17:35:36 +0000 | [diff] [blame] | 132 | pkg_prerm:${PN}() { |
Andrew Geissler | 55bd449 | 2020-03-31 13:43:46 -0500 | [diff] [blame] | 133 | LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service" |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 134 | rm $LINK |
Andrew Geissler | f95063e | 2020-04-14 15:08:43 -0500 | [diff] [blame] | 135 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service" |
| 136 | rm $LINK |
| 137 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service" |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 138 | rm $LINK |
Andrew Geissler | b9b3a4a | 2023-05-12 14:10:34 -0500 | [diff] [blame] | 139 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/xyz.openbmc_project.Control.Host.NMI.service" |
| 140 | rm $LINK |
Andrew Geissler | 4e174d1 | 2020-02-26 14:11:53 -0600 | [diff] [blame] | 141 | # Only uninstall cfam override if p9 system |
| 142 | if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then |
| 143 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service" |
| 144 | rm $LINK |
| 145 | fi |
Dhruvaraj Subhashchandran | c8aa6a1 | 2020-03-09 13:04:32 -0500 | [diff] [blame] | 146 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service" |
| 147 | rm $LINK |
Ramesh Iyyar | d6d9b54 | 2020-09-17 10:02:08 -0500 | [diff] [blame] | 148 | |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 149 | # Remove phal specific units if enabled |
Patrick Williams | 8c561ee | 2021-10-22 14:20:12 -0500 | [diff] [blame] | 150 | if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" = phal ]; then |
Ramesh Iyyar | d6d9b54 | 2020-09-17 10:02:08 -0500 | [diff] [blame] | 151 | LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service" |
| 152 | rm $LINK |
Chirag Sharma | 5ec16a3 | 2020-12-11 03:45:15 -0600 | [diff] [blame] | 153 | |
| 154 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service" |
| 155 | rm $LINK |
Jayanth Othayoth | ad68ba3 | 2021-07-30 06:35:44 -0500 | [diff] [blame] | 156 | |
Andrew Geissler | b9b3a4a | 2023-05-12 14:10:34 -0500 | [diff] [blame] | 157 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.wants/set-spi-mux.service" |
| 158 | rm $LINK |
| 159 | |
Jayanth Othayoth | ad68ba3 | 2021-07-30 06:35:44 -0500 | [diff] [blame] | 160 | LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service" |
| 161 | rm $LINK |
Jayanth Othayoth | ce7dbec | 2021-07-30 06:46:57 -0500 | [diff] [blame] | 162 | |
| 163 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/phal-export-devtree@0.service" |
| 164 | rm $LINK |
Ramesh Iyyar | d0aedb9 | 2022-02-24 03:35:40 -0600 | [diff] [blame] | 165 | |
| 166 | LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.wants/phal-create-boottime-guard-indicator.service" |
| 167 | rm $LINK |
| 168 | LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/phal-create-boottime-guard-indicator.service" |
| 169 | rm $LINK |
Jayanth Othayoth | 633a9cc | 2022-09-12 06:23:45 -0500 | [diff] [blame] | 170 | |
| 171 | LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.wants/op-clock-data-logger@0.service" |
| 172 | rm $LINK |
Andrew Geissler | aa25e2c | 2021-02-01 14:14:25 -0600 | [diff] [blame] | 173 | fi |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 174 | |
Andrew Geissler | aa25e2c | 2021-02-01 14:14:25 -0600 | [diff] [blame] | 175 | # Remove mpreboot specific units if enabled |
| 176 | if [ "${@bb.utils.filter('DISTRO_FEATURES', 'mpreboot', d)}" = mpreboot ]; then |
Andrew Geissler | 88eef19 | 2020-12-17 11:37:11 -0600 | [diff] [blame] | 177 | LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/obmc-host-force-warm-reboot@0.target" |
| 178 | rm $LINK |
| 179 | |
| 180 | LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.requires/op-enter-mpreboot@0.service" |
| 181 | rm $LINK |
| 182 | else |
| 183 | LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.wants/obmc-host-quiesce@0.target" |
| 184 | rm $LINK |
Ramesh Iyyar | d6d9b54 | 2020-09-17 10:02:08 -0500 | [diff] [blame] | 185 | fi |
Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame] | 186 | } |