Deepak Kodihalli | ba5ce78 | 2017-02-05 10:10:44 -0600 | [diff] [blame] | 1 | SUMMARY = "Inventory config for openpower-vpd-parser" |
| 2 | PR = "r1" |
Brad Bishop | 2879d32 | 2018-11-07 14:45:23 -0500 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
Brad Bishop | 1ebdb61 | 2019-09-13 12:18:25 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Deepak Kodihalli | ba5ce78 | 2017-02-05 10:10:44 -0600 | [diff] [blame] | 5 | |
Deepak Kodihalli | ba5ce78 | 2017-02-05 10:10:44 -0600 | [diff] [blame] | 6 | inherit openpower-fru-vpd |
Joseph Reynolds | 79809ea | 2021-02-26 15:37:31 -0600 | [diff] [blame] | 7 | inherit native |
Deepak Kodihalli | ba5ce78 | 2017-02-05 10:10:44 -0600 | [diff] [blame] | 8 | |
| 9 | SRC_URI += "file://inventory" |
| 10 | |
| 11 | PROVIDES += "virtual/openpower-fru-inventory" |
| 12 | |
| 13 | S = "${WORKDIR}" |
| 14 | |
| 15 | do_install() { |
| 16 | # This recipe is supposed to create a systemd environment file |
| 17 | # with values for FRU types and paths. This example recipe |
| 18 | # uses a pre-defined file ($PN/inventory). |
| 19 | |
| 20 | DEST=${D}${inventory_datadir_native} |
| 21 | install -d ${DEST} |
| 22 | install inventory ${DEST} |
| 23 | } |