Deepak Kodihalli | f7a1a78 | 2017-02-20 00:21:12 -0600 | [diff] [blame] | 1 | SUMMARY = "FRU properties config for openpower-vpd-parser" |
| 2 | PR = "r1" |
Brad Bishop | fc00c75 | 2018-11-05 19:28:01 -0800 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
Brad Bishop | 1ebdb61 | 2019-09-13 12:18:25 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Deepak Kodihalli | f7a1a78 | 2017-02-20 00:21:12 -0600 | [diff] [blame] | 5 | |
Deepak Kodihalli | f7a1a78 | 2017-02-20 00:21:12 -0600 | [diff] [blame] | 6 | inherit openpower-fru-vpd |
Joseph Reynolds | 79809ea | 2021-02-26 15:37:31 -0600 | [diff] [blame] | 7 | inherit native |
Deepak Kodihalli | f7a1a78 | 2017-02-20 00:21:12 -0600 | [diff] [blame] | 8 | |
| 9 | SRC_URI += "file://example.yaml" |
| 10 | |
| 11 | PROVIDES += "virtual/openpower-fru-properties" |
| 12 | |
| 13 | S = "${WORKDIR}" |
| 14 | |
| 15 | do_install() { |
| 16 | # This recipe is supposed to create an output yaml file with |
| 17 | # FRU property values extracted from the MRW. This example recipe |
| 18 | # provides a sample output file. |
| 19 | |
| 20 | DEST=${D}${properties_datadir} |
| 21 | install -d ${DEST} |
Ratan Gupta | a782550 | 2017-03-08 01:34:04 +0530 | [diff] [blame] | 22 | install example.yaml ${DEST}/out.yaml |
Deepak Kodihalli | f7a1a78 | 2017-02-20 00:21:12 -0600 | [diff] [blame] | 23 | } |