Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright OpenEmbedded Contributors |
| 3 | # |
| 4 | # SPDX-License-Identifier: MIT |
| 5 | # |
| 6 | |
| 7 | # gi-docgen is a new gnome documentation generator, which |
| 8 | # seems to be a successor to gtk-doc: |
| 9 | # https://gitlab.gnome.org/GNOME/gi-docgen |
| 10 | |
| 11 | # This variable is set to True if api-documentation is in |
| 12 | # DISTRO_FEATURES, and False otherwise. |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 13 | GIDOCGEN_ENABLED ?= "${@bb.utils.contains('DISTRO_FEATURES', 'api-documentation gobject-introspection-data', 'True', 'False', d)}" |
| 14 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 15 | # When building native recipes, disable gi-docgen, as it is not necessary, |
| 16 | # pulls in additional dependencies, and makes build times longer |
| 17 | GIDOCGEN_ENABLED:class-native = "False" |
| 18 | GIDOCGEN_ENABLED:class-nativesdk = "False" |
| 19 | |
| 20 | # meson: default option name to enable/disable gi-docgen. This matches most |
| 21 | # projects' configuration. In doubts - check meson_options.txt in project's |
| 22 | # source path. |
| 23 | GIDOCGEN_MESON_OPTION ?= 'gtk_doc' |
| 24 | GIDOCGEN_MESON_ENABLE_FLAG ?= 'true' |
| 25 | GIDOCGEN_MESON_DISABLE_FLAG ?= 'false' |
| 26 | |
| 27 | # Auto enable/disable based on GIDOCGEN_ENABLED |
| 28 | EXTRA_OEMESON:prepend = "-D${GIDOCGEN_MESON_OPTION}=${@bb.utils.contains('GIDOCGEN_ENABLED', 'True', '${GIDOCGEN_MESON_ENABLE_FLAG}', '${GIDOCGEN_MESON_DISABLE_FLAG}', d)} " |
| 29 | |
| 30 | DEPENDS:append = "${@' gi-docgen-native gi-docgen' if d.getVar('GIDOCGEN_ENABLED') == 'True' else ''}" |
| 31 | |