Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright OpenEmbedded Contributors |
| 3 | # |
| 4 | # SPDX-License-Identifier: MIT |
| 5 | # |
| 6 | |
| 7 | inherit python3native |
| 8 | inherit rust-target-config |
| 9 | |
| 10 | # Common variables used by all Rust builds |
| 11 | export rustlibdir = "${libdir}/rustlib/${RUST_HOST_SYS}/lib" |
| 12 | FILES:${PN} += "${rustlibdir}/*.so" |
| 13 | FILES:${PN}-dev += "${rustlibdir}/*.rlib ${rustlibdir}/*.rmeta" |
| 14 | FILES:${PN}-dbg += "${rustlibdir}/.debug" |
| 15 | |
| 16 | RUSTLIB = "-L ${STAGING_DIR_HOST}${rustlibdir}" |
| 17 | RUST_DEBUG_REMAP = "--remap-path-prefix=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}" |
| 18 | RUSTFLAGS += "${RUSTLIB} ${RUST_DEBUG_REMAP}" |
| 19 | RUSTLIB_DEP ?= "libstd-rs" |
| 20 | RUST_PANIC_STRATEGY ?= "unwind" |
| 21 | |
| 22 | def target_is_armv7(d): |
| 23 | '''Determine if target is armv7''' |
| 24 | # TUNE_FEATURES may include arm* even if the target is not arm |
| 25 | # in the case of *-native packages |
| 26 | if d.getVar('TARGET_ARCH') != 'arm': |
| 27 | return False |
| 28 | |
| 29 | feat = d.getVar('TUNE_FEATURES') |
| 30 | feat = frozenset(feat.split()) |
| 31 | mach_overrides = d.getVar('MACHINEOVERRIDES') |
| 32 | mach_overrides = frozenset(mach_overrides.split(':')) |
| 33 | |
| 34 | v7=frozenset(['armv7a', 'armv7r', 'armv7m', 'armv7ve']) |
| 35 | if mach_overrides.isdisjoint(v7) and feat.isdisjoint(v7): |
| 36 | return False |
| 37 | else: |
| 38 | return True |
| 39 | target_is_armv7[vardepvalue] = "${@target_is_armv7(d)}" |
| 40 | |
| 41 | # Responsible for taking Yocto triples and converting it to Rust triples |
| 42 | def rust_base_triple(d, thing): |
| 43 | ''' |
| 44 | Mangle bitbake's *_SYS into something that rust might support (see |
| 45 | rust/mk/cfg/* for a list) |
| 46 | |
| 47 | Note that os is assumed to be some linux form |
| 48 | ''' |
| 49 | |
| 50 | # The llvm-target for armv7 is armv7-unknown-linux-gnueabihf |
| 51 | if d.getVar('{}_ARCH'.format(thing)) == d.getVar('TARGET_ARCH') and target_is_armv7(d): |
| 52 | arch = "armv7" |
| 53 | else: |
| 54 | arch = oe.rust.arch_to_rust_arch(d.getVar('{}_ARCH'.format(thing))) |
| 55 | |
Patrick Williams | 2390b1b | 2022-11-03 13:47:49 -0500 | [diff] [blame] | 56 | # Substituting "unknown" when vendor is empty will match rust's standard |
| 57 | # targets when building native recipes (including rust-native itself) |
| 58 | vendor = d.getVar('{}_VENDOR'.format(thing)) or "-unknown" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 59 | |
| 60 | # Default to glibc |
| 61 | libc = "-gnu" |
| 62 | os = d.getVar('{}_OS'.format(thing)) |
| 63 | # This catches ARM targets and appends the necessary hard float bits |
| 64 | if os == "linux-gnueabi" or os == "linux-musleabi": |
| 65 | libc = bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', 'hf', '', d) |
| 66 | elif "musl" in os: |
| 67 | libc = "-musl" |
| 68 | os = "linux" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 69 | elif "elf" in os: |
| 70 | libc = "-elf" |
| 71 | os = "none" |
| 72 | elif "eabi" in os: |
| 73 | libc = "-eabi" |
| 74 | os = "none" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 75 | |
| 76 | return arch + vendor + '-' + os + libc |
| 77 | |
| 78 | |
| 79 | # In some cases uname and the toolchain differ on their idea of the arch name |
| 80 | RUST_BUILD_ARCH = "${@oe.rust.arch_to_rust_arch(d.getVar('BUILD_ARCH'))}" |
| 81 | |
| 82 | # Naming explanation |
| 83 | # Yocto |
| 84 | # - BUILD_SYS - Yocto triple of the build environment |
| 85 | # - HOST_SYS - What we're building for in Yocto |
| 86 | # - TARGET_SYS - What we're building for in Yocto |
| 87 | # |
| 88 | # So when building '-native' packages BUILD_SYS == HOST_SYS == TARGET_SYS |
| 89 | # When building packages for the image HOST_SYS == TARGET_SYS |
| 90 | # This is a gross over simplification as there are other modes but |
| 91 | # currently this is all that's supported. |
| 92 | # |
| 93 | # Rust |
| 94 | # - TARGET - the system where the binary will run |
| 95 | # - HOST - the system where the binary is being built |
| 96 | # |
| 97 | # Rust additionally will use two additional cases: |
| 98 | # - undecorated (e.g. CC) - equivalent to TARGET |
| 99 | # - triple suffix (e.g. CC:x86_64_unknown_linux_gnu) - both |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 100 | # see: https://github.com/rust-lang/cc-rs |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 101 | # The way that Rust's internal triples and Yocto triples are mapped together |
| 102 | # its likely best to not use the triple suffix due to potential confusion. |
| 103 | |
| 104 | RUST_BUILD_SYS = "${@rust_base_triple(d, 'BUILD')}" |
| 105 | RUST_BUILD_SYS[vardepvalue] = "${RUST_BUILD_SYS}" |
| 106 | RUST_HOST_SYS = "${@rust_base_triple(d, 'HOST')}" |
| 107 | RUST_HOST_SYS[vardepvalue] = "${RUST_HOST_SYS}" |
| 108 | RUST_TARGET_SYS = "${@rust_base_triple(d, 'TARGET')}" |
| 109 | RUST_TARGET_SYS[vardepvalue] = "${RUST_TARGET_SYS}" |
| 110 | |
| 111 | # wrappers to get around the fact that Rust needs a single |
| 112 | # binary but Yocto's compiler and linker commands have |
| 113 | # arguments. Technically the archiver is always one command but |
| 114 | # this is necessary for builds that determine the prefix and then |
| 115 | # use those commands based on the prefix. |
| 116 | WRAPPER_DIR = "${WORKDIR}/wrapper" |
| 117 | RUST_BUILD_CC = "${WRAPPER_DIR}/build-rust-cc" |
| 118 | RUST_BUILD_CXX = "${WRAPPER_DIR}/build-rust-cxx" |
| 119 | RUST_BUILD_CCLD = "${WRAPPER_DIR}/build-rust-ccld" |
| 120 | RUST_BUILD_AR = "${WRAPPER_DIR}/build-rust-ar" |
| 121 | RUST_TARGET_CC = "${WRAPPER_DIR}/target-rust-cc" |
| 122 | RUST_TARGET_CXX = "${WRAPPER_DIR}/target-rust-cxx" |
| 123 | RUST_TARGET_CCLD = "${WRAPPER_DIR}/target-rust-ccld" |
| 124 | RUST_TARGET_AR = "${WRAPPER_DIR}/target-rust-ar" |
| 125 | |
| 126 | create_wrapper_rust () { |
| 127 | file="$1" |
| 128 | shift |
| 129 | extras="$1" |
| 130 | shift |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 131 | crate_cc_extras="$1" |
| 132 | shift |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 133 | |
| 134 | cat <<- EOF > "${file}" |
| 135 | #!/usr/bin/env python3 |
| 136 | import os, sys |
| 137 | orig_binary = "$@" |
| 138 | extras = "${extras}" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 139 | |
| 140 | # Apply a required subset of CC crate compiler flags |
| 141 | # when we build a target recipe for a non-bare-metal target. |
| 142 | # https://github.com/rust-lang/cc-rs/blob/main/src/lib.rs#L1614 |
| 143 | if "CRATE_CC_NO_DEFAULTS" in os.environ.keys() and \ |
| 144 | "TARGET" in os.environ.keys() and not "-none-" in os.environ["TARGET"]: |
| 145 | orig_binary += "${crate_cc_extras}" |
| 146 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 147 | binary = orig_binary.split()[0] |
| 148 | args = orig_binary.split() + sys.argv[1:] |
| 149 | if extras: |
| 150 | args.append(extras) |
| 151 | os.execvp(binary, args) |
| 152 | EOF |
| 153 | chmod +x "${file}" |
| 154 | } |
| 155 | |
| 156 | WRAPPER_TARGET_CC = "${CC}" |
| 157 | WRAPPER_TARGET_CXX = "${CXX}" |
| 158 | WRAPPER_TARGET_CCLD = "${CCLD}" |
| 159 | WRAPPER_TARGET_LDFLAGS = "${LDFLAGS}" |
| 160 | WRAPPER_TARGET_EXTRALD = "" |
| 161 | WRAPPER_TARGET_AR = "${AR}" |
| 162 | |
| 163 | # compiler is used by gcc-rs |
| 164 | # linker is used by rustc/cargo |
| 165 | # archiver is used by the build of libstd-rs |
| 166 | do_rust_create_wrappers () { |
| 167 | mkdir -p "${WRAPPER_DIR}" |
| 168 | |
| 169 | # Yocto Build / Rust Host C compiler |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 170 | create_wrapper_rust "${RUST_BUILD_CC}" "" "${CRATE_CC_FLAGS}" "${BUILD_CC}" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 171 | # Yocto Build / Rust Host C++ compiler |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 172 | create_wrapper_rust "${RUST_BUILD_CXX}" "" "${CRATE_CC_FLAGS}" "${BUILD_CXX}" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 173 | # Yocto Build / Rust Host linker |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 174 | create_wrapper_rust "${RUST_BUILD_CCLD}" "" "" "${BUILD_CCLD}" "${BUILD_LDFLAGS}" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 175 | # Yocto Build / Rust Host archiver |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 176 | create_wrapper_rust "${RUST_BUILD_AR}" "" "" "${BUILD_AR}" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 177 | |
| 178 | # Yocto Target / Rust Target C compiler |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 179 | create_wrapper_rust "${RUST_TARGET_CC}" "${WRAPPER_TARGET_EXTRALD}" "${CRATE_CC_FLAGS}" "${WRAPPER_TARGET_CC}" "${WRAPPER_TARGET_LDFLAGS}" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 180 | # Yocto Target / Rust Target C++ compiler |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 181 | create_wrapper_rust "${RUST_TARGET_CXX}" "${WRAPPER_TARGET_EXTRALD}" "${CRATE_CC_FLAGS}" "${WRAPPER_TARGET_CXX}" "${CXXFLAGS}" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 182 | # Yocto Target / Rust Target linker |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 183 | create_wrapper_rust "${RUST_TARGET_CCLD}" "${WRAPPER_TARGET_EXTRALD}" "" "${WRAPPER_TARGET_CCLD}" "${WRAPPER_TARGET_LDFLAGS}" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 184 | # Yocto Target / Rust Target archiver |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 185 | create_wrapper_rust "${RUST_TARGET_AR}" "" "" "${WRAPPER_TARGET_AR}" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 186 | |
| 187 | } |
| 188 | |
| 189 | addtask rust_create_wrappers before do_configure after do_patch do_prepare_recipe_sysroot |
| 190 | do_rust_create_wrappers[dirs] += "${WRAPPER_DIR}" |