Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright OpenEmbedded Contributors |
| 3 | # |
| 4 | # SPDX-License-Identifier: MIT |
| 5 | # |
| 6 | |
| 7 | # This class is inherited by recipes whose upstream packages invoke the |
| 8 | # texinfo utilities at build-time. Native and cross recipes are made to use the |
| 9 | # dummy scripts provided by texinfo-dummy-native, for improved performance. |
| 10 | # Target architecture recipes use the genuine Texinfo utilities. By default, |
| 11 | # they use the Texinfo utilities on the host system. If you want to use the |
| 12 | # Texinfo recipe, you can remove texinfo-native from ASSUME_PROVIDED and |
| 13 | # makeinfo from SANITY_REQUIRED_UTILITIES. |
| 14 | |
| 15 | TEXDEP = "${@bb.utils.contains('DISTRO_FEATURES', 'api-documentation', 'texinfo-replacement-native', 'texinfo-dummy-native', d)}" |
| 16 | TEXDEP:class-native = "texinfo-dummy-native" |
| 17 | TEXDEP:class-cross = "texinfo-dummy-native" |
| 18 | TEXDEP:class-crosssdk = "texinfo-dummy-native" |
| 19 | TEXDEP:class-cross-canadian = "texinfo-dummy-native" |
| 20 | DEPENDS:append = " ${TEXDEP}" |
| 21 | |
| 22 | # libtool-cross doesn't inherit cross |
| 23 | TEXDEP:pn-libtool-cross = "texinfo-dummy-native" |
| 24 | |