Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | SUMMARY = "Utility scripts for internationalizing XML" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | HOMEPAGE = "https://launchpad.net/intltool" |
| 3 | DESCRIPTION = "Utility scripts for internationalizing XML. This tool automatically extracts translatable strings from oaf, glade, bonobo ui, nautilus theme and other XML files into the po files." |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 4 | SECTION = "devel" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 5 | LICENSE = "GPL-2.0-only" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 7 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 8 | SRC_URI = "http://launchpad.net/${BPN}/trunk/${PV}/+download/${BP}.tar.gz \ |
| 9 | file://intltool-nowarn.patch \ |
| 10 | file://perl-522-deprecations.patch \ |
| 11 | file://remove-perl-check.patch \ |
| 12 | file://noperlcheck.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 13 | " |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | SRC_URI[md5sum] = "12e517cac2b57a0121cda351570f1e63" |
| 15 | SRC_URI[sha256sum] = "67c74d94196b153b774ab9f89b2fa6c6ba79352407037c8c14d5aeb334e959cd" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 16 | |
| 17 | UPSTREAM_CHECK_URI = "https://launchpad.net/intltool/trunk/" |
| 18 | |
| 19 | DEPENDS = "libxml-parser-perl-native" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 20 | RDEPENDS:${PN} = "gettext-dev libxml-parser-perl" |
| 21 | DEPENDS:class-native = "libxml-parser-perl-native gettext-native" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 22 | |
| 23 | inherit autotools pkgconfig perlnative |
| 24 | |
| 25 | export PERL = "${bindir}/env perl" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 26 | PERL:class-native = "/usr/bin/env nativeperl" |
| 27 | PERL:class-nativesdk = "/usr/bin/env perl" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 28 | |
| 29 | # gettext is assumed to exist on the host |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | RDEPENDS:${PN}:class-native = "libxml-parser-perl-native" |
| 31 | RRECOMMENDS:${PN} = "perl-modules" |
| 32 | RRECOMMENDS:${PN}:class-native = "" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | FILES:${PN}-dev = "" |
| 35 | FILES:${PN} += "${datadir}/aclocal" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | INSANE_SKIP:${PN} += "dev-deps" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 38 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 39 | BBCLASSEXTEND = "native nativesdk" |