Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | SUMMARY = "Software watchdog" |
| 2 | DESCRIPTION = "Watchdog is a daemon that checks if your system is still \ |
| 3 | working. If programs in user space are not longer executed it will reboot \ |
| 4 | the system." |
| 5 | HOMEPAGE = "http://watchdog.sourceforge.net/" |
| 6 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=172030&atid=860194" |
| 7 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 8 | LICENSE = "MIT" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 9 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 10 | |
| 11 | SRC_URI = " \ |
| 12 | file://watchdog.default \ |
| 13 | file://watchdog.conf \ |
| 14 | " |
| 15 | |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 16 | # The default value is 60 seconds when null. |
| 17 | WATCHDOG_TIMEOUT ??= "" |
| 18 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 19 | do_install() { |
| 20 | install -Dm 0644 ${WORKDIR}/watchdog.default ${D}${sysconfdir}/default/watchdog |
| 21 | install -Dm 0644 ${WORKDIR}/watchdog.conf ${D}${sysconfdir}/watchdog.conf |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 22 | |
| 23 | if [ -n "${WATCHDOG_TIMEOUT}" ]; then |
| 24 | echo "watchdog-timeout = ${WATCHDOG_TIMEOUT}" >> ${D}/etc/watchdog.conf |
| 25 | fi |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 26 | } |
| 27 | |