blob: 46dc94154dc573e723a06ee7eb0a57a81e3791f3 [file] [log] [blame]
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06001SUMMARY = "smemstat reports the physical memory usage taking into consideration shared memory"
2HOMEPAGE = "https://github.com/ColinIanKing/smemstat"
3LICENSE = "GPL-2.0-or-later"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "ncurses"
8
9SRC_URI = "git://github.com/ColinIanKing/smemstat.git;protocol=https;branch=master"
Patrick Williams2a254922023-08-11 09:48:11 -050010SRCREV = "72efeb08ccdb22f57054279d25e3c522e8e1d4c3"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060011
12S = "${WORKDIR}/git"
13
14inherit bash-completion
15
16do_compile () {
17 oe_runmake smemstat
18}
19
20do_install () {
21 oe_runmake DESTDIR=${D} install
22}