blob: 1e23d87a6753c6b846307e0b26acaf3620661ef3 [file] [log] [blame]
Patrick Williams2a254922023-08-11 09:48:11 -05001SUMMARY = "Module::Build::Tiny - A tiny replacement for Module::Build"
2DESCRIPTION = "Many Perl distributions use a Build.PL file instead of a \
3Makefile.PL file to drive distribution configuration, build, test and \
4installation. Traditionally, Build.PL uses Module::Build as the underlying \
5build system. This module provides a simple, lightweight, drop-in replacement. \
6Whereas Module::Build has over 6,700 lines of code; this module has less than \
7120, yet supports the features needed by most distributions."
8SECTION = "libs"
9
10HOMEPAGE = "http://search.cpan.org/~leont/Module-Build-Tiny/"
11
12LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
13LIC_FILES_CHKSUM = "file://LICENSE;md5=147a7b891d1584d3d33e478b1f2327c5"
14
15DEPENDS = "libextutils-config-perl-native libextutils-helpers-perl-native libextutils-installpaths-perl-native"
16
17SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/Module-Build-Tiny-${PV}.tar.gz"
18SRC_URI[sha256sum] = "be193027e2debb4c9926434aaf1aa46c9fc7bf4db83dcc347eb6e359ee878289"
19
20S = "${WORKDIR}/Module-Build-Tiny-${PV}"
21
22inherit cpan_build ptest-perl
23
24RDEPENDS:${PN} += " \
25 libextutils-config-perl \
26 libextutils-helpers-perl \
27 libextutils-installpaths-perl \
28 perl-module-carp \
29 perl-module-cpan \
30 perl-module-data-dumper \
31 perl-module-encode-encoding \
32 perl-module-exporter \
33 perl-module-extutils-cbuilder \
34 perl-module-extutils-cbuilder-base \
35 perl-module-extutils-install \
36 perl-module-extutils-makemaker \
37 perl-module-extutils-parsexs \
38 perl-module-file-path \
39 perl-module-file-spec \
40 perl-module-file-temp \
41 perl-module-getopt-long \
42 perl-module-io-handle \
43 perl-module-ipc-cmd \
44 perl-module-json-pp \
45 perl-module-load \
46 perl-module-metadata \
47 perl-module-parse-cpan-meta \
48 perl-module-perl-ostype \
49 perl-module-pod-man \
50 perl-module-tap-harness-env \
51 perl-module-test-more \
52 perl-module-text-parsewords \
53 perl-module-xsloader \
54"
55
56RDEPENDS:${PN}-ptest += " \
57 packagegroup-core-buildessential \
58 perl-dev \
59 perl-module-blib \
60 perl-module-ipc-open2 \
61"
62
63INSANE_SKIP:${PN}-ptest += "dev-deps"
64
65BBCLASSEXTEND = "native"