blob: b7709aa1ca9476a53b40c7a6ef2dbf8b40657bb5 [file] [log] [blame]
Andrew Geissler8f840682023-07-21 09:09:43 -05001SUMMARY = "A coverage plugin to provide sensible default settings"
2HOMEPAGE = "https://github.com/asottile/covdefaults"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a3da826da635201a80d2fb40f3034929"
5
6# Use GitHub SRC_URI, as pypi package does not include tests
7SRC_URI += " \
8 git://github.com/asottile/covdefaults.git;branch=main;protocol=https \
9 file://run-ptest \
10"
11
12SRCREV = "007f5aff5d1c817883385a5f61f742dd11776dc6"
13
14S = "${WORKDIR}/git"
15
16inherit setuptools3 ptest
17
18RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-coverage \
20"
21
22RDEPENDS:${PN}-ptest += " \
23 ${PYTHON_PN}-pytest \
24"
25
26do_install_ptest() {
27 install -d ${D}${PTEST_PATH}
28 cp -rf ${S}/tests ${D}${PTEST_PATH}
29}
30
31BBCLASSEXTEND = "native nativesdk"