blob: d5100dd78e782d7e93e31518f5a5cc6bc858ae93 [file] [log] [blame]
Andrew Geissler615f2f12022-07-15 14:00:58 -05001SUMMARY = "Pika is a RabbitMQ (AMQP 0-9-1) client library for Python."
2DESCRIPTION = " \
3Pika is a pure-Python implementation of the AMQP 0-9-1 protocol \
4including RabbitMQ's extensions. \
5"
6SECTION = "devel/python"
7HOMEPAGE = "https://pika.readthedocs.io"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=678ec81495ba50edf81e84e4f1aa69f3"
10
Andrew Geissler3eeda902023-05-19 10:14:02 -050011SRC_URI[sha256sum] = "b2a327ddddf8570b4965b3576ac77091b850262d34ce8c1d8cb4e4146aa4145f"
Andrew Geissler615f2f12022-07-15 14:00:58 -050012
13inherit pypi python_setuptools_build_meta
14
15PYPI_PACKAGE = "pika"
16
17DEPENDS += " \
18 ${PYTHON_PN}-setuptools-scm-native \
19 ${PYTHON_PN}-toml-native \
20"
21
22RDEPENDS:${PN} += " \
23 ${PYTHON_PN}-logging \
24 ${PYTHON_PN}-tornado \
25 ${PYTHON_PN}-twisted \
26"