blob: 2d85d789c7047103123b8a283cc3d471de94c079 [file] [log] [blame]
Patrick Williams2a254922023-08-11 09:48:11 -05001DESCRIPTION = "Python module for Semantic Versioning"
2HOMEPAGE = "https://github.com/python-semver/python-semver"
3BUGTRACKER = "https://github.com/python-semver/python-semver"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=d9da679db3bdce30a1b4328d5c474f98"
6
7SRC_URI[md5sum] = "b7502c12ce325ffffeab694fed52f6f5"
8SRC_URI[sha256sum] = "9ec78c5447883c67b97f98c3b6212796708191d22e4ad30f4570f840171cbce1"
9
10inherit pypi python_setuptools_build_meta ptest
11
12BBCLASSEXTEND = "native nativesdk"
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
18DEPENDS += " python3-setuptools-scm-native"
19
20RDEPENDS:${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22"
23
24do_install_ptest() {
25 cp -rf ${S}/tests ${D}${PTEST_PATH}/
26}