blob: 40adc34c10f71d06b3076a7dcc17b19c881c068e [file] [log] [blame]
Andrew Geissler3eeda902023-05-19 10:14:02 -05001SUMMARY = "A pure-python library for embedding CoSWID data"
2HOMEPAGE = "https://github.com/hughsie/python-uswid"
3SECTION = "devel/python"
4LICENSE = "LGPL-2.1-or-later"
5
6DEPENDS += " python3-cbor2 python3-lxml python3-pefile"
Patrick Williamsb542dec2023-06-09 01:26:37 -05007RDEPENDS:${PN} += " \
8 python3-cbor2 \
9 python3-json \
10 python3-lxml \
11 python3-netclient \
12"
Andrew Geissler3eeda902023-05-19 10:14:02 -050013LIC_FILES_CHKSUM = "file://LICENSE;md5=40d2542b8c43a3ec2b7f5da31a697b88"
14
15SRC_URI = "git://github.com/hughsie/python-uswid.git;branch=main;protocol=https"
16SRCREV = "3223034abef88ae29cf79fdc7fe11ec7e21e11ff"
17S = "${WORKDIR}/git"
18
19inherit setuptools3 python3native
20
21BBCLASSEXTEND = "native nativesdk"