blob: 9880c07053e4099e7735f21125c406cb297875ad [file] [log] [blame]
Patrick Williams2a254922023-08-11 09:48:11 -05001SUMMARY = "A suite of libcamera-based apps"
2DESCRIPTION = "This is a small suite of libcamera-based apps that aim to \
3copy the functionality of the existing \"raspicam\" apps."
4HOMEPAGE = "https://github.com/raspberrypi/libcamera-apps"
5SECTION = "console/utils"
6
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://license.txt;md5=a0013d1b383d72ba4bdc5b750e7d1d77"
9
10SRC_URI = "\
11 git://github.com/raspberrypi/libcamera-apps.git;protocol=https;branch=main \
12 file://0001-utils-version.py-use-usr-bin-env-in-shebang.patch \
13"
14PV = "1.2.1+git${SRCPV}"
15SRCREV = "1c1d1c1a2a86d70cf873edc8bb72d174f037973a"
16
17S = "${WORKDIR}/git"
18
19DEPENDS = "libcamera libexif jpeg tiff libpng boost"
20
21PACKAGECONFIG ??= "drm"
22PACKAGECONFIG[libav] = "-Denable_libav=true, -Denable_libav=false, libav"
23PACKAGECONFIG[drm] = "-Denable_drm=true, -Denable_drm=false, libdrm"
24PACKAGECONFIG[egl] = "-Denable_egl=true, -Denable_egl=false, virtual/egl"
25PACKAGECONFIG[qt] = "-Denable_qt=true, -Denable_qt=false, qtbase"
26PACKAGECONFIG[opencv] = "-Denable_opencv=true, -Denable_opencv=false, opencv"
27PACKAGECONFIG[tflite] = "-Denable_tflite=true, -Denable_tflite=false, tensorflow-lite"
28
29inherit meson pkgconfig
30
31NEON_FLAGS = ""
32NEON_FLAGS:aarch64 = "-Dneon_flags=arm64"
33NEON_FLAGS:arm:raspberrypi3 = "-Dneon_flags=armv8-neon"
34NEON_FLAGS:arm:raspberrypi4 = "-Dneon_flags=armv8-neon"
35EXTRA_OEMESON += "${NEON_FLAGS}"
36
37# QA Issue: /usr/bin/camera-bug-report contained in package libcamera-apps requires /usr/bin/python3
38do_install:append() {
39 rm -v ${D}/${bindir}/camera-bug-report
40}