Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Support for reading various archive formats" |
| 2 | DESCRIPTION = "C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats" |
| 3 | HOMEPAGE = "http://www.libarchive.org/" |
| 4 | SECTION = "devel" |
| 5 | LICENSE = "BSD-2-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=d499814247adaee08d88080841cb5665" |
| 7 | |
| 8 | DEPENDS = "e2fsprogs-native" |
| 9 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 10 | PACKAGECONFIG ?= "zlib bz2 xz zstd ${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)}" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 11 | |
| 12 | DEPENDS_BZIP2 = "bzip2-replacement-native" |
| 13 | DEPENDS_BZIP2:class-target = "bzip2" |
| 14 | |
| 15 | PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl," |
| 16 | PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr," |
| 17 | PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib," |
| 18 | PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,${DEPENDS_BZIP2}," |
| 19 | PACKAGECONFIG[xz] = "--with-lzma,--without-lzma,xz," |
| 20 | PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl," |
| 21 | PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2," |
| 22 | PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat," |
| 23 | PACKAGECONFIG[lzo] = "--with-lzo2,--without-lzo2,lzo," |
| 24 | PACKAGECONFIG[nettle] = "--with-nettle,--without-nettle,nettle," |
| 25 | PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4," |
| 26 | PACKAGECONFIG[mbedtls] = "--with-mbedtls,--without-mbedtls,mbedtls," |
| 27 | PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd," |
| 28 | |
| 29 | EXTRA_OECONF += "--enable-largefile --without-iconv" |
| 30 | |
| 31 | SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz" |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame^] | 32 | SRC_URI += "file://configurehack.patch" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 33 | UPSTREAM_CHECK_URI = "http://libarchive.org/" |
| 34 | |
| 35 | SRC_URI[sha256sum] = "ba6d02f15ba04aba9c23fd5f236bb234eab9d5209e95d1c4df85c44d5f19b9b3" |
| 36 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame^] | 37 | CVE_STATUS[CVE-2023-30571] = "upstream-wontfix: upstream has documented that reported function is not thread-safe" |
| 38 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 39 | inherit autotools update-alternatives pkgconfig |
| 40 | |
| 41 | CPPFLAGS += "-I${WORKDIR}/extra-includes" |
| 42 | |
| 43 | do_configure[cleandirs] += "${WORKDIR}/extra-includes" |
| 44 | do_configure:prepend() { |
| 45 | # We just need the headers for some type constants, so no need to |
| 46 | # build all of e2fsprogs for the target |
| 47 | cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/ |
| 48 | } |
| 49 | |
| 50 | ALTERNATIVE_PRIORITY = "80" |
| 51 | |
| 52 | PACKAGES =+ "bsdtar" |
| 53 | FILES:bsdtar = "${bindir}/bsdtar" |
| 54 | |
| 55 | ALTERNATIVE:bsdtar = "tar" |
| 56 | ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar" |
| 57 | ALTERNATIVE_TARGET[tar] = "${bindir}/bsdtar" |
| 58 | |
| 59 | PACKAGES =+ "bsdcpio" |
| 60 | FILES:bsdcpio = "${bindir}/bsdcpio" |
| 61 | |
| 62 | ALTERNATIVE:bsdcpio = "cpio" |
| 63 | ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio" |
| 64 | ALTERNATIVE_TARGET[cpio] = "${bindir}/bsdcpio" |
| 65 | |
| 66 | BBCLASSEXTEND = "native nativesdk" |