Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "A thin layer of graphic data types" |
| 2 | HOMEPAGE = "http://ebassi.github.io/graphene/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a7d871d9e23c450c421a85bb2819f648" |
| 5 | |
| 6 | GNOMEBASEBUILDCLASS = "meson" |
| 7 | |
| 8 | inherit gnomebase gobject-introspection gtk-doc |
| 9 | |
| 10 | SRC_URI[archive.sha256sum] = "a37bb0e78a419dcbeaa9c7027bcff52f5ec2367c25ec859da31dfde2928f279a" |
| 11 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 12 | # Disable neon support by default on ARM-32 platforms because of the |
| 13 | # following upstream bug: https://github.com/ebassi/graphene/issues/215 |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 14 | PACKAGECONFIG ?= "gobject-types ${@bb.utils.contains('TUNE_FEATURES', 'aarch64', 'neon', '', d)}" |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 15 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 16 | PACKAGECONFIG[gobject-types] = "-Dgobject_types=true,-Dgobject_types=false,glib-2.0" |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 17 | PACKAGECONFIG[neon] = "-Darm_neon=true,-Darm_neon=false," |
| 18 | |
| 19 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 20 | GIR_MESON_DISABLE_FLAG = 'disabled' |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 21 | |
| 22 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 23 | |
| 24 | EXTRA_OEMESON = "-Dinstalled_tests=false" |
| 25 | |
| 26 | FILES:${PN} += "${libdir}/graphene-1.0" |
| 27 | |
| 28 | BBCLASSEXTEND = "native nativesdk" |