Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Python interface to libarchive" |
| 2 | DESCRIPTION = "A Python interface to libarchive. It uses the standard ctypes module to \ |
| 3 | dynamically load and access the C library." |
| 4 | HOMEPAGE = "https://github.com/Changaco/python-libarchive-c" |
| 5 | LICENSE = "CC0-1.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=bcab380227a83bc147350b40a81e6ffc" |
| 7 | |
| 8 | PYPI_PACKAGE = "libarchive-c" |
| 9 | |
| 10 | inherit pypi setuptools3 |
| 11 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 12 | SRC_URI[sha256sum] = "7bcce24ea6c0fa3bc62468476c6d2f6264156db2f04878a372027c10615a2721" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 13 | |
| 14 | RDEPENDS:${PN} += "\ |
| 15 | libarchive \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 16 | python3-ctypes \ |
| 17 | python3-mmap \ |
| 18 | python3-logging \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 19 | " |
| 20 | |
| 21 | BBCLASSEXTEND = "native" |