blob: 821332fe7cdeccaf4ab403379d059a1f45a1ffc7 [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "Implements a XML/HTML/XHTML Markup safe string for Python"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002HOMEPAGE = "http://github.com/mitsuhiko/markupsafe"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
5
Patrick Williams73bd93f2024-02-20 08:07:48 -06006SRC_URI[sha256sum] = "d283d37a890ba4c1ae73ffadf8046435c76e7bc2247bbb63c00bd1a709c6544b"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007
8PYPI_PACKAGE = "MarkupSafe"
Patrick Williams73bd93f2024-02-20 08:07:48 -06009inherit pypi python_setuptools_build_meta ptest
Andrew Geissler9aee5002022-03-30 16:27:02 +000010
Patrick Williams73bd93f2024-02-20 08:07:48 -060011RDEPENDS:${PN} += "python3-stringold"
Andrew Geissler9aee5002022-03-30 16:27:02 +000012
13BBCLASSEXTEND = "native nativesdk"
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060020 python3-pytest \
21 python3-unittest-automake-output \
Andrew Geissler9aee5002022-03-30 16:27:02 +000022"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/tests
26 cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/
27}