Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "OpenGL / OpenGL ES Reference Compiler" |
| 2 | DESCRIPTION = "Glslang is the official reference compiler front end for the \ |
| 3 | OpenGL ES and OpenGL shading languages. It implements a strict interpretation \ |
| 4 | of the specifications for these languages. It is open and free for anyone to use, \ |
| 5 | either from a command line or programmatically." |
| 6 | SECTION = "graphics" |
| 7 | HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler" |
| 8 | LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2a2b5acd7bc4844964cfda45fe807dc3" |
| 10 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 11 | SRCREV = "ee2f5d09eaf8f4e8d0d598bd2172fce290d4ca60" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 12 | SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https;branch=main \ |
| 13 | file://0001-generate-glslang-pkg-config.patch \ |
| 14 | " |
| 15 | PE = "1" |
| 16 | # These recipes need to be updated in lockstep with each other: |
| 17 | # glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools |
| 18 | # vulkan-validation-layers, vulkan-utility-libraries. |
| 19 | # The tags versions should always be sdk-x.y.z, as this is what |
| 20 | # upstream considers a release. |
| 21 | UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)" |
| 22 | S = "${WORKDIR}/git" |
| 23 | |
| 24 | inherit cmake python3native |
| 25 | |
| 26 | DEPENDS = "spirv-tools" |
| 27 | |
| 28 | EXTRA_OECMAKE = " \ |
| 29 | -DCMAKE_BUILD_TYPE=Release \ |
| 30 | -DBUILD_SHARED_LIBS=ON \ |
| 31 | -DENABLE_PCH=OFF \ |
| 32 | -DENABLE_CTEST=OFF \ |
| 33 | -DBUILD_EXTERNAL=OFF \ |
| 34 | -DALLOW_EXTERNAL_SPIRV_TOOLS=ON \ |
| 35 | " |
| 36 | |
| 37 | BBCLASSEXTEND = "native nativesdk" |