Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "OpenGL function pointer management library" |
| 2 | HOMEPAGE = "https://github.com/anholt/libepoxy/" |
| 3 | SECTION = "libs" |
| 4 | |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=58ef4c80d401e07bd9ee8b6b58cf464b" |
| 7 | |
| 8 | SRC_URI = "https://github.com/anholt/${BPN}/releases/download/${PV}/${BP}.tar.xz \ |
| 9 | " |
| 10 | SRC_URI[md5sum] = "e2845de8d2782b2d31c01ae8d7cd4cbb" |
| 11 | SRC_URI[sha256sum] = "002958c5528321edd53440235d3c44e71b5b1e09b9177e8daf677450b6c4433d" |
| 12 | UPSTREAM_CHECK_URI = "https://github.com/anholt/libepoxy/releases" |
| 13 | |
| 14 | inherit meson pkgconfig distro_features_check |
| 15 | |
| 16 | REQUIRED_DISTRO_FEATURES = "opengl" |
| 17 | REQUIRED_DISTRO_FEATURES_class-native = "" |
| 18 | REQUIRED_DISTRO_FEATURES_class-nativesdk = "" |
| 19 | |
| 20 | PACKAGECONFIG[egl] = "-Degl=yes, -Degl=no, virtual/egl" |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 21 | PACKAGECONFIG[x11] = "-Dglx=yes, -Dglx=no -Dx11=false, virtual/libx11 virtual/libgl" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} egl" |
| 23 | |
| 24 | EXTRA_OEMESON += "-Dtests=false" |
| 25 | |
Brad Bishop | 79641f2 | 2019-09-10 07:20:22 -0400 | [diff] [blame] | 26 | PACKAGECONFIG_class-native = "egl x11" |
| 27 | PACKAGECONFIG_class-nativesdk = "egl x11" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |
| 30 | |
| 31 | # This will ensure that dlopen will attempt only GL libraries provided by host |
| 32 | do_install_append_class-native() { |
| 33 | chrpath --delete ${D}${libdir}/*.so |
| 34 | } |
| 35 | |
| 36 | do_install_append_class-nativesdk() { |
| 37 | chrpath --delete ${D}${libdir}/*.so |
| 38 | } |