Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 1 | # Common code for dbus applications using python. |
| 2 | |
| 3 | inherit allarch |
| 4 | inherit obmc-phosphor-systemd |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 5 | |
| 6 | RDEPENDS_${PN} += "python-dbus python-pygobject" |
Brad Bishop | 51607d2 | 2015-10-18 22:00:15 -0400 | [diff] [blame] | 7 | INSTALL_NAME ?= "${PN}" |
| 8 | SCRIPT_NAME ?= "${INSTALL_NAME}.py" |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 9 | |
| 10 | do_install_append() { |
| 11 | # install the script |
| 12 | install -d ${D}${sbindir} |
Brad Bishop | 51607d2 | 2015-10-18 22:00:15 -0400 | [diff] [blame] | 13 | install -m 0755 ${S}/${SCRIPT_NAME} ${D}${sbindir}/${INSTALL_NAME} |
Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 14 | } |